"Failed source list update for product" error message is logged in the Srcupdatemgr.log file on a Systems Management Server 2003 client computer (886687)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP1
  • Microsoft Systems Management Server 2003

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Microsoft Systems Management Server (SMS) 2003 cannot update the source list for a previously installed Windows Installer-based program. This symptom occurs even if the advertised Windows Installer-based program is run by a user with the correct permissions. Additionally, depending on your SMS configuration, error messages may be logged in the Srcupdatemgr.log file on the SMS client computer :
  • If you have not installed the hotfix that is described in Knowledge Base article 831198, and the user running the program does not have sufficient rights, the following error message is logged in the SrcUpdateMgr.log file:
    The Failed source list update for product {90280409-6000-11D3-8CFE-0050048383C9}, error 80070005


    Note The SrcUpdateMgr.log file is located in the \Winnt\Wystem32\Ccm\Logs folder on the SMS client computer.
  • If you have installed the hotfix referenced in Knowledge Base article 831198, the following error message is logged in the SrcUpdateMgr.log file, regardless of the users permissions:
    Failed source list update for product {90280409-6000-11D3-8CFE-0050048383C9}, error 80070645


    Note The SrcUpdateMgr.log file is located in the \Winnt\Wystem32\Ccm\Logs folder on the SMS client computer.
For additional information about the hotfix that is described in Microsoft Knowledge Base article number 831198, click the following article number to view the article in the Microsoft Knowledge Base:

831198 Software packages do not install on Systems Management Server 2003 clients

CAUSE

This problem occurs because the "Always Install with Elevated Privileges" Windows Installer Group Policy setting is enabled. In this case, users with limited permissions cannot access the update source list for the installed program. This causes SMS to fail when it tries to update the source list for all per-user non-managed installations by using the context of the user with limited permissions.

Important We recommend that you do not enable the "Always Install with Elevated Privileges" Group Policy setting. Any computer that has the " Always Install with Elevated Privileges" Group Policy setting enabled is a potential security risk.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.SMS 2003
         Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Jun-2004  17:50  2.0.156.0         254,455  Deployac.exe     
   25-Dec-2003  15:35                    274,944  Sms2003ac-kb886687-x86.msp
   25-Dec-2003  13:30  2.50.2726.154      40,960  Smsse.dll        
   25-Dec-2003  15:35  2.50.2726.155     169,984  Srcupdatemgr.dll  
   05-Nov-2004  01:23                        558  Smsconfig.inf
   25-Dec-2003  13:30  2.50.2726.154      40,960  Smsse.dll        
SMS 2003 Service Pack 1
         Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Jun-2004  17:50  2.0.156.0         254,455  Deployac.exe     
   20-Oct-2004  11:10                      3,204  Patch.ini
   20-Oct-2004  11:10                    282,112  Sms2003ac-sp1-kb886687-x86.msp
   25-Dec-2003  13:30  2.50.2726.154      40,960  Smsse.dll        
   20-Oct-2004  11:10  2.50.3174.1115    178,176  Srcupdatemgr.dll  
   15-Dec-2004  20:37                        562  Smsconfig.inf
   25-Dec-2003  13:30  2.50.2726.154      40,960  Smsse.dll        

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To successfully install this hotfix, you must create new registry sub key, and then enable the "Enable user to browse for source while elevated Windows Installer Group Policy setting .To do this, follow these steps:
  1. Log on to the client computer as a member of the Administrators group.
  2. Click Start, click Run, type regedit, and then click OK.
  3. In Registry Editor, locate and then click the following registry sub key:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type AllowLockdownBrowse for the DWORD value name, and then press ENTER.
  6. Right-click the new DWORD value, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.
  9. Click Start, click Run, type mmc in the Open box, and then click OK.
  10. In the MMC snap-in dialog box, click Add/Remove snap-in on the File menu.
  11. In the Add/Remove snap-in dialog box, click Add.
  12. In the Add Standalone Snap-in dialog box, click Group Policy, and then click Add.
  13. In the Select Group Policy Object dialog box, click Local Computer,, click Finish, click Close, and then click OK.
  14. In the snap-in, expand Local Computer Policy, expand Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Windows Installer.
  15. Double-click Enable user to browse for source while elevated.
  16. On the Setting tab, click Enabled, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected In Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix KB886687 kbAudITPRO