You receive an "Unavailable Critical Extension" error message when you try to query against a global catalog server or a Windows Server 2003-based domain controller (886683)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When you try to query against a global catalog (GC) server or a Microsoft Windows Server 2003-based domain controller (DC), you may receive the following error message:
Unavailable Critical Extension

CAUSE

This problem occurs when you perform a Virtual List Views (VLV) extension search to the Active Directory directory service. The VLV extension search stops responding because Active Directory cannot handle the search operation.

RESOLUTION

Service Pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Oct-2004  16:43  5.2.3790.224    1,532,416  Ntdsa.dll        
   21-Oct-2004  16:43  5.2.3790.212       32,768  Ntdsatq.dll      
   20-Oct-2004  18:54  5.2.3790.224      242,176  Ntdsutil.exe     
   20-Oct-2004  18:26                    179,440  Schema.ini
   19-Sep-2004  11:41  5.2.3790.212       59,392  Ws03res.dll      
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Oct-2004  01:38  5.2.3790.224    4,056,064  Ntdsa.dll        
   21-Oct-2004  01:38  5.2.3790.212       82,432  Ntdsatq.dll      
   20-Oct-2004  03:23  5.2.3790.224      568,832  Ntdsutil.exe     
   20-Oct-2004  03:23                    179,440  Schema.ini
   18-Sep-2004  18:43  5.2.3790.212       58,880  Ws03res.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was corrected in Microsoft Windows Server 2003 Service Pack 1.

MORE INFORMATION

This hotfix removes the VLV object identifier (also known as OID) advertisement from the RootDSE object. After you apply this hotfix, you cannot use a client to perform a VLV extension search to Active Directory.

After you install this hotfix, you must use the Active Directory Service Interfaces (ADSI) Edit tool to add a DisableVLVSupport value to the msds-Other-Settings attribute. To add the DisableVLVSupport value, install Windows Support Tools and then follow these steps.

Note The ADSI Edit tool is located in the Windows Support Tools folder on the Microsoft Windows Server 2003 CD. To install Windows Support Tools, run the Setup.exe program. The Setup.exe program is located in the Support\Tools\Setup folder.
  1. Click Start, click Run, type Adsiedit.msc, and then press ENTER.
  2. In the ADSI Edit tool, expand the Configuration[DomainController] node.
  3. Expand the CN=Configuration,DC=DomainName container.
  4. Expand the CN=Services object.
  5. Expand the CN=Windows NT object.
  6. Right-click the CN=Directory Service object. Click Properties.
  7. In the Attributes list, click msds-Other-Settings. Click Edit.
  8. In the Value to add box, type DisableVLVSupport=1. Click Add.
  9. Click OK two times. Close the ADSI Edit tool.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB886683 kbAudITPRO