Windows Small Business Server 2003 clients cannot download Connection Manager (886622)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When remote users log on to Remote Web Workplace on a Microsoft Windows Small Business Server 2003-based computer, they cannot download the Connection Manager package, and they receive one or both of the following error messages:

Message 1
Because this is a shared or public computer, Connection Manager cannot be downloaded. As a security precaution, Connection Manager can be downloaded only to a computer that is not shared or public.
Message 2
The Connection Manager Package can only be downloaded on a trusted computer.
Remote users cannot access the option on the Remote Web Workplace logon page to make the client computer trusted.

CAUSE

This issue may occur when the AllowTrusted registry entry is changed from the default value of 1 to 0.

RESOLUTION

To resolve this issue, change the value of the AllowTrusted registry entry on the Windows Small Business Server 2003-based computer:

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click to select the following registry subkey: HKey_Local_Machine\Software\Microsoft\SmallBusinessServer\RemoteUserPortal .
  3. In the right pane, right-click AllowTrusted, and then click Modify.
  4. In the Value data box, change the value from 0 to 1, and then click OK.
  5. Quit Registry Editor
Remote users will now be able to deselect the following option on the Remote Web Workplace logon page to make the client computer trusted:

I'm using a public or shared computer


Modification Type:MinorLast Reviewed:2/16/2005
Keywords:kbtshoot kbprb KB886622 kbAudITPRO