"The document name or path is not valid" error message when you open a new document in a Windows SharePoint Services document library that is hosted on a Windows Small Business Server 2003-based computer (886619)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

You have a Windows SharePoint Services document library that is hosted on a Microsoft Windows Small Business Server 2003-based computer. When you use Microsoft Word 2000 to open a new document in this document library, you may receive the following error message:
The document name or path is not valid.
Additionally, no new document opens in Word 2000. Instead, the default template opens.

CAUSE

This issue may occur if you have both Microsoft Office 2000 and Microsoft Office Outlook 2003 installed on the client computer.

RESOLUTION

To resolve this issue, remove the Windows SharePoint Services component of Office 2000 on the client computer. To do this, follow these steps.

Note This procedure removes Windows SharePoint Services support from Outlook 2003. For example, after you remove the Windows SharePoint Services component of Office 2000, you cannot link items between Windows SharePoint Services and the Outlook calendar.
  1. On the client computer, insert the Microsoft Office 2003 CD or the Microsoft Office 2000 CD. If the CD does not play automatically, locate the CD folder, and then double-click Setup.exe.
  2. If you are prompted to enter the Product Key, do this.
  3. Click Add or Remove Features, and then click Next.
  4. Click to select the Outlook check box, click to select the Choose advanced customization of applications check box, and then click Next.
  5. Expand Office Tools, expand Windows SharePoint Services Support, click the drive icon next to Windows SharePoint Services Support, and then click Not Available.
  6. Click Update.
  7. When the installation is complete, click OK.

WORKAROUND

To work around this issue, remove Word 2000 from the client computer, and then upgrade to Office 2003 or Office XP on the client computer. To do this, follow these steps:
  1. On the client computer, click Start, point to Settings, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. Click Microsoft Office 2000 Professional, and then click Change.
  4. Click Add or Remove Features, click the drive icon next to Microsoft Word for Windows, and then click Not Available.
  5. Click Update Now.
  6. When you are prompted that the Setup program has finished successfully, click OK.
  7. Insert the Microsoft Office 2003 CD or the Microsoft Office XP CD. If the CD does not play automatically, locate the CD folder, and then double-click Setup.exe.
  8. If you are prompted to enter the Product Key, do this, and then click Next.
  9. Enter your user information, and then click Next.
  10. Click to select the I accept the terms in the license agreement check box, and then click Next two times.
  11. When the Setup program is completed, click Finish.

MORE INFORMATION

If you modify the default template and you later want to restore the default template, follow these steps:
  1. Open the SharePoint site (http://companyweb/default.aspx), and then click General Documents.
  2. Under Actions, click Modify settings and columns.
  3. Under General Settings, locate the Document Template row of the General Documents column, and then click Edit Template.
  4. In the File Download dialog box, click OK.
  5. In Microsoft Word 2000, click New on the File menu to create a new blank template.
  6. Click File, click Exit, and then click Yes to save the changes to Template.doc.
  7. On the Customize General Documents page, click Go Back to "General Documents."
  8. Click New Document.
Word 2000 displays the new blank template that you saved in step 6.

Modification Type:MinorLast Reviewed:11/19/2004
Keywords:kbtshoot kbprb KB886619 kbAudITPRO