Data for a deleted user is not set to "Disabled" in the Plans database in Hosted Exchange 2003 (886614)



The information in this article applies to:

  • Microsoft Solutions for Windows-based Hosting, including Hosted Exchange 2003

SYMPTOMS

When you view the data for a deleted user, the Previous Value in the Events Table appears "Enabled." This problem occurs in the Microsoft Solutions for Windows-based Hosting, including Hosted Exchange 2003 Customer database. The Changed Value appears "Deleted." The Previous Value is supposed to be "Disabled" because the user has a status of "Disabled" at the time that you delete the user.

CAUSE

This problem occurs because the Hosted Exchange 2003 DisableUser procedure does not set the status of the user to "Disabled" in the Plans database. When you disable a user by using the sample Web interface, the StatusTypeCode field in the HECustomerDB/Customers table is not updated. The status code remains "Enabled." The account is correctly disabled in the Active Directory directory service.

STATUS

Microsoft is researching this problem and will post more information in this article when the information becomes available.

REFERENCES

For additional information about Microsoft Exchange Server 2003, visit the following Microsoft Web site: http://support.microsoft.com/exch2003

Modification Type:MajorLast Reviewed:11/8/2004
Keywords:kbtshoot kbprb KB886614 kbAudDeveloper