The Works Calendar may stop responding when you import an ICalender *.ics file (886556)



The information in this article applies to:

  • Microsoft Works 8.0
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2006

SYMPTOMS

When you try to import ICalendar (*.ics) files into the Microsoft Works Calendar, the Works Calendar may stop responding. Alternatively, you may receive the following error message:

CALENDAR -- Error in OleDbSvc.DLL

Warning!: HResult of 0x80004005 (-2147467259) returned
Error Source: Microsoft JET Database Engine
Error Description: Cannot open any more tables.

CAUSE

This issue may occur if you are trying to import an *.ics file that has several recurring appointments. When the Works Calendar imports this information, an individual appointment is created for each day that the event occurs up to the year 2040. If the *.ics file contains many recurring appointments, the Works Calendar may run out of memory. The Works Calendar cannot import these files.

WORKAROUND

To work around this problem, manually enter the appointments. To do this, follow these steps:
  1. On the File menu, click New Appointment.
  2. In the Title box, type or select a name for the appointment.
  3. Under When, type or select the start time and the end time for the appointment.
  4. Type or select other information about the appointment.

Modification Type:MajorLast Reviewed:10/25/2005
Keywords:kbImport kbprb kbtshoot KB886556 kbAudEndUser