FIX: You cannot download large files from an ASP.NET application on a computer that is running IIS 6.0 (886461)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition



SYMPTOMS

After you configure a Microsoft ASP.NET application on a computer that is running Microsoft Internet Information Services (IIS) 6.0, you experience the following symptoms:
  • If you try to transfer a large amount of data to the IIS 6.0 server, the transfer is not successful. When this behavior occurs, you receive the following error message:
    The underlying connection was closed: An unexpected error occurred on a receive.
  • If you view the %WINDIR%\System32\logfiles\Httperr#.log file, you notice a Timer_EntityBody entry that corresponds to the unsuccessful download operation.

    Note In this log file name, # represents the sequence number of the log file.

CAUSE

This problem occurs because the Http.sys kernel mode driver prematurely resets the connection to the Web server. Therefore, the file transfer operation is interrupted.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size   File name
   --------------------------------------------------------
   20-Oct-2004  18:36  5.2.3790.224      335,872  Http.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Microsoft Windows Server 2003 Service Pack 1 (SP1) addresses all known timer-related issues including some issues that were found after the problem that is mentioned in this article.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about additional logging properties that are available in the Httperr#.log file, click the following article number to view the article in the Microsoft Knowledge Base:

832975 Additional properties are now available for logging in the Httperr#.log file in IIS 6.0


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE KB886461 kbAudDeveloper kbAudITPRO