FIX: Windows Media Player 9 Series for Windows frequently accesses the registry and may affect performance (886423)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Server 2003
  • Microsoft Windows Media Player 9 Series for Windows XP

SYMPTOMS

If you use a registry monitoring tool, such as Regmon, you may notice that Microsoft Windows Media Player 9 Series for Windows frequently accesses the registry. This problem may occur even though Windows Media Player 9 Series for Windows may not be playing content. Frequent registry access may affect performance, particularly in a simultaneous multi-user environment, such as Terminal Services. If several users are running Windows Media Player 9 Series for Windows at the same time on a computer that is running Terminal Server, performance degradation may result.

Regmon is a third-party tool from Sysinternals.

CAUSE

Typically, Windows Media Player 9 Series for Windows repeatedly checks Media Library elements and then updates those Media Library elements. Currently, data about the Media Library is stored in the registry. Therefore, Windows Media Player 9 Series for Windows appears to poll several registry keys too much. Windows Media Player 9 Series for Windows does this to try to keep the Media Library updated. This hotfix reduces the amount of polling that is performed by the Windows Media Player 9 Series for Windows.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Windows Media Player 9 Series for Microsoft Windows XP

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsXP-KB886423-v2-x86-enu.exe package now.

Windows Media Player 9 Series for Microsoft Windows 2000 and for Microsoft Windows Server 2003

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia9-KB886423-x86-ENU.exe package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Sep-2004  18:48  9.0.0.3256      4,870,144  Wmp.dll          

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbtshoot kbfix kbQFE kbHotfixServer KB886423 kbAudDeveloper kbAudEndUser kbAudITPRO kbAudOEM