You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003 (886346)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Server ActiveSync

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you synchronize your mobile device with Microsoft Exchange Server 2003, you receive the following error message:
Error code: HTTP_500

Synchronization failed due to an error on the server. Try again.

CAUSE

Exchange ActiveSync typically locates the mailbox by using the left-hand side (LHS) of the primary Simple Mail Transfer Protocol (SMTP) address. The problem that is described in the Symptoms section occurs if the following conditions are true:
  • The user has multiple SMTP addresses.
  • The primary SMTP address does not match the default Recipient Policy.

RESOLUTION

To resolve this issue, install Microsoft Exchange Server 2003 Service Pack 2 (SP2). If applying Exchange Server 2003 SP2 is not an option, add a registry key to force Exchange ActiveSync to locate the mailbox by using the secondary SMTP addresses. To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Note This change requires that you restart the Microsoft Internet Information Services (IIS) Admin service.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key: HKEY_Local_Machine\System\CurrentControlSet\Services\MasSync\Parameters\
  3. Right-click Parameters, click New, and then click String Value.
  4. "New value #1" is selected. Type SMTPProxy and then press ENTER to rename the value. Right-click SMTPProxy, and then click Modify.
  5. In the String Data line, type the SMTP domain of your default Recipient Policy. For example, type contosoltd.com.
  6. Click OK to quit Registry Editor.
  7. Restart the IIS Admin service. To do this, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. In the list of services, right-click IIS Admin service, and then click Restart.
After you apply the new registry setting, Exchange ActiveSync will look through all the SMTP addresses to locate the mailbox. For example, a user at Contoso, Ltd. has the following SMTP configuration:

SMTP:admin@contoso.com <------------Primary SMTP address

smtp:admin@contosoltd.com

After you add the SMTPProxy value and set it to contosoltd.com, Exchange ActiveSync will correctly look for the admin@contosoltd.com mailbox.

Important
  • Make sure that the back-end mailbox server is running a version of Exchange Server that is later than Microsoft Exchange Server 2003 Service Pack 1 (build 6.5.7226).
  • For this resolution to work, on the Exchange servers, you must disable the DisableSMTPMailboxAddressing registry entry, if it exists. To turn off this registry entry, set the value of the following registry entry to 0:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\DisableSMTPMailboxAddressing


Modification Type:MinorLast Reviewed:4/18/2006
Keywords:kbprb KB886346