Advertised programs may not finish successfully in Systems Management Server 2003 (886156)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you run an advertised program on a computer that is running the Microsoft Systems Manager (SMS) 2003 Advanced Client, the program may not finish successfully. If this behavior occurs, you may receive entries in the %Windir%\System32\CCM\Logs\Execmgr.log file that are similar to the following:
Rolling over to network access account to check content location $$<execmgr><DateTime><ThreadID> ConnectNetResource failed with error code 0x000004c3 $$<execmgr><DateTime><ThreadID>

CAUSE

This problem may occur when the following conditions are true:
  • The client computer that is running the program is also running the Microsoft Systems Management Server (SMS) 2003 Advanced Client.
  • The advertised program uses the Network Access account to connect to a distribution point.
  • The advertised program runs immediately after another advertised program that is designed to start and then finish in less than one second.

WORKAROUND

To work around this problem, use one of the following methods:

Method 1: For programs that are chained

  • If only one member of the program chain starts and then finishes in less than one second, and the sequence of the programs is not important, move the member of the program chain that starts and finishes in less than one second to the end of the chain.
  • If the members of a program chain that start and then finish in less than one second can run independently of the rest of the chain, remove those members from the chain, and then advertise them separately.
  • Try to introduce a one-second delay into the chain immediately after the members of the program chain that start and then finish in less than one second.

Method 2: For programs that are not chained together

Create another advertisement for the program to the same collection with a new assignment time that is later than the original assignment time.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem may occur when the advertised program is part of a program chain. However, it may also occur when one advertised program starts immediately after another advertised program that starts and finishes in less than one second.

Programs that are advertised as mandatory will automatically retry in 10 minutes if the initial run of the mandatory program fails. Most of the time, this problem will not occur when the Advanced Client retries the mandatory advertisement.

Optional programs that are optional do not automatically retry. If this problem occurs when you use an optional program, use one of the methods that are described in the "Workaround" section.

This problem may occur when a member of a chained program starts after the previous member of the chain starts and stops in less than one second. The problem will not occur if members of the program chain do not stop and start in less than one second.

To access distribution points, the computer that is running the SMS 2003 Advanced Client tries to use the security context of the user who is logged on to the client computer to connect to the distribution point. If the computer that is running the SMS 2003 Advanced Client cannot connect to the distribution point with the security context of the user who is logged on to the client computer, the computer tries to connect with the Network Access account for the Advanced Client.

For additional information about software distribution client accounts, click the following article number to view the article in the Microsoft Knowledge Base:

826871 Client accounts that are used in software distribution in Systems Management Server 2003

For additional information about how to chain multiple programs, click the following article number to view the article in the Microsoft Knowledge Base:

828947 How to deploy multiple Office products in a single installation in Office 2003


Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbSMSDistribution kbwinservperf kbMgmtServices kbprb KB886156 kbAudITPRO