Systems Management Server 2003 Deployment Readiness Wizard reports duplicate client IDs after you move a discovered computer to a different domain (886152)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you run the Deployment Readiness Wizard (DRW.exe) on a Microsoft Systems Management Server (SMS) 2003 site in preparation for an upgrade, you may receive the following warning message:
One or more clients assigned to a site in the SMS database have duplicate client ID's

CAUSE

This behavior typically occurs when the following conditions are true:
  1. You used Active Directory System Discovery to discover a client computer.
  2. You moved the discovered client computer to a different domain.
  3. The client record still exists in the Active Directory directory service in the client computer's original domain.

RESOLUTION

To resolve this problem, use Active Directory Users and Computers to delete the client record in the original domain. To do this, follow these steps.

Note These steps must be performed on a domain controller in the SMS client's original domain.
  1. Use an account that has administrative permissions to log on to a domain controller. On a Microsoft Windows 2000-based domain controller, click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers. On a Microsoft Windows Server 2003-based domain controller, click Start, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Expand your Active Directory domain, and then click Computers.
  3. In the details pane, right-click the computer that you want, and then click delete.
  4. When you are prompted to confirm that you want to delete the object, click Yes.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB886152 kbAudITPRO