A package is sent to the wrong clients or is not sent at all if you try to distribute a package to a collection that is based on a query in Systems Management Server 2003 (886136)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Members of a Microsoft Systems Management Server (SMS) 2003 collection are deleted. This symptom occurs if all the following conditions are true:
  • The collection is based on a query.
  • The SMS Collection Evaluator component receives an error when it tries to evaluate the collection members.
The SMS Collection Evaluator component later repopulates the collection if the membership rule is successfully evaluated. If you have advertisements that run on a repeating schedule, the advertisements may run again on the clients after the scheduled time.

Entries that are similar to the following entries are logged in the Colleval.log file:
[40001][1205][Microsoft][ODBC SQL Server Driver][SQL Server]Transaction (Process ID 54) was deadlocked on 
	lock | communication buffer resources with another process and has been chosen as the deadlock 
	victim. Rerun the transaction.
CCollectionSource_SQL::RefreshResults - could not execute SQL cmd QueryScript
Results refreshed for collection collectionID, 36089 entries changed.
Could not evaluate one of the rules for collection collectionID.
The following events are logged in the Application log, where CollectionName is the name of the collection, MembershipRule is the name of the collection's membership rule, and collectionID is the eight digit collection ID:Event ID: 2542

Description: SMS Collection Evaluator failed to update the query rule "MembershipRule" of collection "CollectionName" (CollectionID).Event ID: 2511

Description: SMS Collection Evaluator failed to update the membership of collection "CollectionID".Event ID: 2544

Description: SMS Collection Evaluator is updating the results for collection "CollectionID", there are 0 member changes. Event ID: 2543

Description: "SMS Collection Evaluator failed to evaluate some of the query rules for collection "CollectionName" (CollectionID)"

CAUSE

This problem occurs if a Microsoft SQL Server deadlock condition occurs when the SMS Collection Evaluator component tries to evaluate the membership rule for the collection. When the SMS Collection Evaluator component encounters an error, the query-refresh task continues, and then returns no members for the collection. Therefore, the collection members are removed from the collection until the collection is reevaluated correctly.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2003 Service Pack 1 (SP1) to apply this hotfix.

Restart requirement

This hotfix stops the following services, and then prompts you to perform a site reset:
  • SMS_SITE_COMPONENT_MANAGER
  • SMS_EXECUTIVE
  • SMS_SQL_MONITOR
  • SMS Agent Host
  • Windows Management Instrumentation
.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Oct-2004  04:35  2.50.3174.1132    262,144  Basesql.dll
   20-Oct-2004  04:35  2.50.3174.1132  1,765,376  Basesvr.dll
1 The English SMS 2003 International Client Pack 1 version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Oct-2004  09:35  2.50.3174.1132    262,144  Basesql.dll      
   20-Oct-2004  09:35  2.50.3174.1132  1,765,376  Basesvr.dll  
The English SMS 2003 International Client Pack 2 version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Oct-2004  09:35  2.50.3174.1132    262,144  Basesql.dll      
   20-Oct-2004  09:35  2.50.3174.1132  1,765,376  Basesvr.dll 

Hotfix installation instructions

You must apply this hotfix to all SMS 2003 SP1 primary site servers in your hierarchy. To install this hotfix, follow these steps:
  1. Copy the Sms2003-sp1-kb886136-x86-enu.exe file to a folder on your primary site server.
  2. Run Sms2003-sp1-kb886136-x86-enu.exe on your primary site server.
  3. Click Next to start the Setup wizard.
  4. Click I Agree, and then click Next.
  5. Click Continue to let the Setup wizard stop the SMS services.
  6. Click Yes to let the Setup wizard reset the SMS site. If you click No, you must manually perform a site reset to make sure that the hotfix installation is completed. To manually perform a site reset, follow these steps:
    1. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Setup.
    2. Warning Do not complete this step until you read this warning. By default, Remove SMS is selected. You must make sure that you click Modify or reset the current installation to perform a site reset. If you do not clear the Remove SMS option, the Setup program automatically removes your SMS installation.

      Click Next two times, click Modify or reset the current installation, and then click Next.
    3. Click Next four times, and then click Finish.
    4. Click Yes to reset the site.

WORKAROUND

To work around this problem, move the clients into subcollections of the primary collection. By dividing the larger collection into smaller subcollections, you can base the primary collection on a smaller query. When you use smaller subcollections, you have more control over advertisements. You can still distribute advertisements to the whole collection by using the Include members of subcollections option on the General tab of the advertisement properties dialog box.

For more information about distributing software in Microsoft Systems Management Server (SMS) 2003, see "Distributing Software" in the Systems Management Server 2003 Concepts, Planning, and Deployment Guide. To view this information online, visit the following Microsoft Web site:For more information about managing collections and queries in SMS 2003, see "Managing Collections and Queries" in the Systems Management Server 2003 Concepts, Planning, and Deployment Guide. To view this information online, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

This hotfix does not prevent the SQL Deadlock condition. This hotfix makes a change in the way that SMS handles the condition by preventing Collection Evaluator from removing the query results when a SQL error occurs and leaving the collection empty. This change is accomplished by forcing an "Access Denied" message back to SQL during the deadlock. This message preserves the query results and the collection membership. This "Access Denied" error message may appear in the SQL or Colleval logs and is expected behavior. For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/18/2006
Keywords:kbQFE kbHotfixServer kbSMSPackage kbSMSDistribution kbSMSDeploy kbSMSClients kbSMS2003bug kbtshoot kbAdvertisement kbPackage kbCollections kberrmsg kbPerformance kbSoftwareDist KB886136 kbAudITPRO