Remote Assistance cannot connect to a Windows XP SP2 client computer in SMS Administrator console in Systems Management Server 2003 (886120)



The information in this article applies to:

  • Microsoft Systems Management Server 2003
  • the operating system: Microsoft Windows XP Professional Service Pack 2 (SP2)

SYMPTOMS

After you enable Remote Assistance in Windows Firewall on a Microsoft Windows XP Service Pack 2 (SP2) client computer, you may experience the following symptoms:
  • Remote Assistance sessions initiated from the Microsoft Systems Management Server (SMS) Administrator console to the Windows XP SP2 client computer fail, although Remote Assistance sessions requested by the Windows XP SP2 client succeed.
  • You receive the following error message when you try to start Remote Assistance in the SMS Administrator console:
    The remote server machine does not exist or is unavailable.

CAUSE

In Windows XP SP2, the default configuration of Windows Firewall blocks the required TCP port 135 and Helpsvc.exe program that are used by Remote Assistance.

RESOLUTION

To resolve this problem, add TCP port 135 and the Helpsvc.exe program to the Windows Firewall exceptions list on the Windows XP SP2 client.

To do this, follow these steps:
  1. Log on to the Windows XP SP2 client with administrative credentials.
  2. Click Start, and then click Control Panel.
  3. Double-click Windows Firewall, and then click the Exceptions tab.
  4. Click Add Program to open the Add a Program dialog box.
  5. Click Browse to open the Browse dialog box.
  6. Browse to and select C:\Windows\PCHealth\Helpctr\Binaries\Helpsvc.exe, and then click Open.
  7. Click OK to close the Add a Program dialog box.
  8. Click Add Port.
  9. In the Name box, type RPC_TCP135, and then in the Port number box, type 135.
  10. Click OK to close Windows Firewall dialog box.
We recommend that you use Remote Assistance instead of Remote Tools on client computers that support Remote Assistance. To enable SMS Remote Tools, add the following port for each remote tool that is required.
TCP PortFunction
2701Allows general contact, reboot, and ping
2702Remote control
2703Chat
2704File transfer
For more information about ports that are used by SMS remote control, click the following article number to view the article in the Microsoft Knowledge Base:

256884 TCP and UDP ports that are used by Remote Control have changed in SMS 2.0 Service Pack 2



For information about how to configure Windows Firewall in Windows XP Service Pack 2, search for "Windows Firewall" in Windows XP Help.

REFERENCES

For more information about SMS features that might be affected by Windows XP SP2, see the "Client personal firewalls" section of the "Scenarios and Procedures for Microsoft Systems Management Server 2003: Security" article. To view this article, visit the following Microsoft Web site:
For additional information about how to troubleshoot Windows Management Instrumentation (WMI) issues in Windows XP SP2, click the following article number to view the article in the Microsoft Knowledge Base:

875605 How to troubleshoot WMI-related issues in Windows XP Service Pack 2


Modification Type:MajorLast Reviewed:8/26/2005
Keywords:kbsmsAdmin kbSMSRemote Tools kbSMS2003spfix kbSMS2003bug KB886120 kbAudITPRO