When you upgrade your Systems Management Server (SMS) 2.0 site server to SMS 2003 and then reset the site server, the SMS_SQL_MONITOR component does not connect back to the Status Manager inbox on the site server (886083)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

You upgrade your Microsoft Systems Management Server (SMS) 2.0 site server to SMS 2003. After you use the SMS service account to reset the site server, the SMS_SQL_MONITOR component does not connect back to the Status Manager inbox on the site server.

Additionally, you receive the following error messages when you open the Smsdbmon.log file in the \SMS\Logs folder:

WARNING: Still waiting for SMS_INBOX_MANAGER to create the "Status Manager" inbox. Sleeping for 60 seconds. The operating system reported error 5: Access is denied.

ERROR: Still waiting for SMS_INBOX_MANAGER to create the "Status Manager" inbox. Sleeping for 60 seconds. The operating system reported error 5: Access is denied.

CAUSE

This problem occurs when the SMS service account is not a member of the Domain Admins group.

During the initial SMS 2.0 installation on the site server, the SMSServer_Sitecode connection account receives permissions for the Statmgr.box folder. The Statmgr.box folder is set to inherit the permissions from its parent folder inbox. The SMS_SiteSystemToSiteServerConnection_Sitecode connection group is included in the discretionary access control list (DACL) for the Statmgr.box folder during the upgrade from SMS 2.0 to SMS 2003. However, the SMS service account has insufficient rights to reset the DACL of the Statmgr.box folder. Therefore, the SMS service account cannot add the SMS_SiteSystemToSiteServerConnection_Sitecode connection group to the DACL when you reset the site server. The SMS_INBOX_MANAGER component in SMS 2003 cannot access the Statmgr.box folder unless the SMS_SiteSystemToSiteServerConnection_Sitecode connection group is included in the DACL.

Note In this scenario, the same problem may occur with other inbox folders in the SMS_Sitecode share folder.

WORKAROUND

To work around this problem, use one of the following methods.

Method 1

Add the SMS service account to the Domain Admins group. Then, use the account to reset the site server after you upgrade from SMS 2.0 to SMS 2003.

Method 2

Change the location of the server connection account from the domain server to the site server. To do this, follow these steps:
  1. Run the Aclreset.exe program on the site server.
  2. Create a new account that is named Srv_Connect on the site server. Add this account to the SMS_SiteSystemToSiteServerConnection_Sitecode connection group on the site server.
  3. On the site server, create a file that is named Smsaccountsetup.ini in the %windir%\System32 folder.
  4. Add the following information to the SMSaccountsetup.ini file:

    [ServerAccount]
    Name=SiteServerName\Srv_Connect
    Password=password
  5. Reset the site server.

Method 3

After you upgrade from SMS 2.0 to SMS 2003, use a local account that is a member of the SMS_SiteSystemToSiteServerConnection_Sitecode connection group to reset the site server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbSMS2003bug kbprb KB886083 kbAudITPRO