SYMPTOMS
You cannot install a Systems Management Server (SMS) 2003 Advanced Client on a domain
controller by using a logon script, even when the script uses the /DC command-line option with the Capinst.exe command. When this behavior occurs, an entry that is similar to the following appears in the Capinst.log file:*** Starting Installation *** -
Wed Dec 08 11:26:06 2004
1 Command line argument(s):
C:\CLIENT\I386\capinst.exe
Checking OS Version:
This machine is a
Domain Controller.
Windows 2000 or greater detected.
This machine is
a Domain Controller - Client will not be installed on this machine.
***
Installation Complete *** - Wed Dec 08 11:26:06 2004
Note The Capinst.log file is located in the following folder:
C:\Documents and Settings\UserName\Local Settings\Temp
By default, the Local
Settings folder is hidden.
CAUSE
This behavior occurs when the following conditions are true:
- The user who logs on to the domain controller is not a member of the local Administrators group.
- The Domain controllers check box in the Client Push Installation Properties dialog box on the SMS site server is not selected.
This behavior occurs because the user who logs on to the domain controller must be a member of the local Administrators group to install a client by using a logon script.
If a user who is not a member of the local Administrators group logs on to a domain controller, Capinst.exe does not install
the SMS client. Instead, Capinst.exe creates a client configuration request (CCR) and
sends it to the management point. This CCR requests that the site server initiate an
SMS Advanced Client push installation on the domain
controller. However, because the
Domain controllers check box in the
Client Push Installation Properties dialog on the SMS site server is not selected, the site server ignores the CCR. The site server does not install the SMS client on the domain controller.