You cannot transfer a file to a Systems Management Server 2003 client computer when the name of the file contains a double-byte character set (DBCS) character (886048)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When you use Microsoft Systems Management Server (SMS) 2003 Remote Tools to transfer a file to a SMS 2003 client computer, you experience the following symptoms:
  • The name of the file that you want to transfer to the client does not appear on the file transfer interface on the SMS 2003 client computer.
  • Files that are on the SMS 2003 client computer do not appear in the folder box that is displayed at the bottom of the Remote Tools window.
  • When you copy a file to the SMS 2003 client computer, you receive error messages that are similar to the following:
    Error: Could not create 'FileName'. The destination file may be read-only or in use.

CAUSE

This problem occurs when the following conditions are all true:
  • The server is running the English version of SMS 2003.
  • International Client Packs are applied to the server.
  • The name of the file that you want to transfer contains at least one double-byte character set (DBCS) character.
  • The SMS 2003 client computer is an international-language client that supports DBCS characters, such as a Japanese client or a Chinese client.
  • The International Client Pack (ICP) that is installed on the server interprets the DBCS character differently than the SMS 2003 client computer.

WORKAROUND

To work around this problem, follow these steps:
  1. Use Windows Explorer to rename the file that you want to transfer so that it does not contain a DBCS character in the name of the file or in the file path.
  2. Transfer the file that you have renamed to the SMS 2003 client computer. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Administrator Console.
    2. Expand Site Database (SiteCode - SiteName), expand Site Hierarchy, expand SiteCode - SiteName, expand Collections, and then click the collection that contains the SMS 2003 client computer that you want to transfer a file to.
    3. In the left pane, locate and then right-click the SMS 2003 client computer, point to All Tasks, and then click Start Remote Tools.
    4. On the Remote Tools window, click Tools, and then click File Transfer.

      Note SMS starts the File Transfer tool in the Remote Tools window. The folder box that appears at the top of the window lists the files and the folders that are on the computer that you want to copy files and folders from. The folder box that appears at the bottom lists the files and the folders that are on the SMS 2003 client computer.
    5. In the folder box that appears at the top of the window, locate the file that you renamed.
    6. In the folder box that appears at the bottom of the window, locate the folder on the SMS 2003 client that you want to transfer the file to.
    7. Drag the file that you have renamed from the top folder box (source) to the bottom folder box (destination).
Note You may have to rename the file on the SMS 2003 client computer after it has been transferred if the name of the file that you transferred must contain DBCS characters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

832103 How to determine the version number of Systems Management Server 2003

For additional information about ICPs, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbServer kbSMSClients kbClient kbtshoot kbwinservperf kbSMS2003bug kbMgmtServices kbprb KB886048 kbAudITPRO