The software distribution may fail when you try to distribute the English version of the scan tool program by using the Japanese version of Systems Management Server 2003 (886047)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Your site server is running the Japanese version of Microsoft Systems Management Server (SMS) 2003. When you use the Distribute Software Updates Wizard (DSUW) to distribute the English version of the scan tool program from this site server to client computers that are running the English version of SMS, the software distribution may fail. When this problem occurs, an error message that is similar to the following may be logged in the Patchinstall.log file on the SMS client:
Trying to call Scan Program $$<Software Updates Installation Agent><Tue Aug 10 16:30:23.098 2004 Tokyo Standard Time><thread=1364 (0x554)>
Program passed to the Agent does not match any program available in registry $$<Software Updates Installation Agent><Tue Aug 10 16:30:23.098 2004 Tokyo Standard Time><thread=1364 (0x554)>
Error in getting the scan program name and command line, Scan will not be called~~ $$<Software Updates Installation Agent><Tue Aug 10 16:30:23.098 2004 Tokyo Standard Time><thread=1364 (0x554)>
Unable to get path for scan program, Agent will not evaluate software updates $$<Software Updates Installation Agent><Tue Aug 10 16:30:23.098 2004 Tokyo Standard Time><thread=1364 (0x554)>
Note The Patchinstall.log file is located in the WINNT\System32\CCM\Logs folder on the SMS client.

CAUSE

This problem occurs if you select the expedited version of the scan tool program on the Select an Inventory Scanning program page of the DSUW. For example, this problem occurs if you select scan (expedited) instead of scan.

In this case, the English version of the SMS client cannot correctly interpret the word "expedited" that appears in double-byte character set (DBCS) format in the Japanese version of SMS on your site server. Therefore, the English version of the SMS client cannot locate the correct scan tool program.

RESOLUTION

To resolve this problem, you must select a non-expedited version of the software update when you use the DSUW. For example, you must select scan instead of scan (expedited) on the Select an Inventory Scanning program page of the DSUW.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB886047 kbAudITPRO