A software package does not appear in the software inventory for a client in Systems Management Server 2003 (886046)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

In Microsoft Systems Management Server 2003, you run an inventory query for product details of software. In the resulting inventory report, you notice that a software package that is installed on a Microsoft Systems Management Server 2003 client does not appear in the software inventory for that client.

CAUSE

This problem occurs if the following conditions are true:
  • In the Software Inventory Client Agent properties, the Reporting detail option is set to include product details.
  • In the Software Inventory Client Agent properties, the Reporting detail option is set not to include file details.
  • File version information for the software package on the client returns null values.

WORKAROUND

To work around this problem, you must modify the Reporting detail option for the Software Inventory Client Agent to include file details. To do this, follow these steps:
  1. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. Expand Site Database (SiteCode - SiteName), expand Site Hierarchy, expand SiteCode - SiteName, expand Site Settings, and then click Client Agents.
  3. In the right pane, right-click Software Inventory Client Agent, and then click Properties.
  4. Click the Inventory Collection tab.
  5. In the Reporting detail box, click to select File Details, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The Reporting detail option specifies the level of inventory information that you want to appear in Resource Explorer. When you select File Details, the report includes all scanned files. Product Details makes the report include software products only when manufacturer information is present. When you inventory for product details only, the resulting query will exclude software packages that return a null value when they are queried for the file version.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbprb kbwinservperf kbMgmtServices kbinfo KB886046 kbAudITPRO