The Microsoft Exchange Information Store service may stop responding when you register an event sink on the system mailbox in Exchange Server 2003 (885910)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

When you register a custom global information store event sink on a computer that is running Microsoft Exchange Server 2003, the Microsoft Exchange Information Store service (Store.exe) may stop responding (hang).

CAUSE

This problem may occur if the following conditions are true:
  • You are running Exchange 2003 on a multiprocessor computer.
  • You register the custom global information store event sink on the system mailbox.
This problem occurs because Exchange may incorrectly free a structure before the Microsoft Exchange Information Store service has finished working with the structure. This causes the Microsoft Exchange Information Store service to stop responding (hang).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about this problem in Microsoft Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:

884035 The Exchange Information Store service stops responding when you register an event sink on the system mailbox in Exchange 2000 Server


For additional information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbExchange2003preSP2fix kbfix kbBug KB885910 kbAudITPRO