EFI boot manager entries are reordered when you deploy a Windows Server 2003 image that you created by using the Sysprep tool and an imaging solution (885891)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

You are using the Microsoft System Preparation tool (Sysprep) and an imaging solution to image a computer that is running Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems. When you deploy the image to a computer, the Extensible Firmware Interface (EFI) boot manager options are reordered. For example, this problem occurs when you follow these steps:
  1. You set the boot order options in Non-Volatile Random Access Memory (NVRAM) to the following:
    PXE1
    2003
    PXE2
    EFI Shell
  2. You run the Sysprep tool.
  3. You deploy the image.
In this example, the boot order is reordered to the following on the computer that you deployed the image to:
PXE1
PXE2
EFI Shell
2003
Additionally, if Pre-Boot Execution Environment (PXE) startup fails, the computer stops at the EFI shell for keyboard input instead of starting Windows Server 2003.

CAUSE

This problem occurs because the Setupcl.exe file changes the partition GUIDs on GUID partition table (GPT) disks. The NVRAM boot entry for Windows is no longer valid because it points to the old GUID. Therefore, the Setupcl.exe file deletes this entry and re-creates it at the end of the boot order list.

Note The Setupcl.exe file is a Sysprep component that regenerates new security identifiers (SIDs) for the computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Oct-2004  01:50  5.2.3790.228       79,360  Setupcl.exe  
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about boot options in EFI NVRAM, visit the following Microsoft Web site:For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB885891 kbAudITPRO