The Backup utility removes a backup file if it encounters an unexpected error during a restore operation in a Windows Server 2003-based cluster environment (885890)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

You are using a Microsoft Windows Server 2003-based cluster environment that contains at least two computers that are running Microsoft Exchange Server 2003. You use the Backup utility to save a backup file for one storage group on one computer to a second storage group on another computer. Later, you try to use the Backup utility to restore the backup file from the second storage group to the first storage group. However, the restore operation stops abruptly, and you receive an error message that contains an option to click OK. Before you click OK, you verify that the backup file is available in the first storage group. However, when you look for the backup file after you click OK, the backup file is not in the first storage group.

Note You experience the same problem if you use a removable storage device to perform the backup and restore operation.

CAUSE

This problem occurs because the Backup utility removes a backup file if it encounters an unexpected error during a restore operation.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntbackup.exe5.2.3790.2241,171,96821-Oct-200422:22x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntbackup.exe5.2.3790.2243,342,84821-Oct-200409:52IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This feature was first included in Windows Server 2003 Service Pack 1.

MORE INFORMATION

Steps to reproduce the problem

Cluster environment

  1. Configure a cluster environment that consists of two computers.
  2. Save the backup file for a storage group to another storage group by using the Backup utility.
  3. Restore the data from the second storage group to the first storage group.
  4. When you restore the data, interrupt the network connection between the two computers.
  5. When you see an error message that contains an option to click OK, restore the network connection between the two computers.
  6. Click OK, and then finish the Backup utility.
  7. Verify whether the backup file exists in the source storage group.

Removable storage device

  1. Connect a removable storage device to a computer.
  2. Use the Backup utility to save a backup file to the removable storage device.
  3. Use the Backup utility to restore the backup file to the computer.
  4. When you restore the file, disconnect the removable storage device from the computer.
  5. When you see an error message that contains an option to click OK , reconnect the removable storage device to the computer.
  6. Verify that you can access the removable storage device and that the backup file exists on the removable storage device.
  7. Click OK.
  8. Verify whether the backup file exists on the removable storage device.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP1fix kbBug kbfix kbpubtypekc KB885890 kbAudEndUser kbAudITPRO