Windows Server 2003-based computer stops responding during an automatic logon and restart stress test (885889)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

During an automatic logon and restart stress test of a Microsoft Windows Server 2003-based computer, the computer stops responding. For example, this problem may occur when you configure the computer to use automatic logon, and you set the Scheduled Tasks feature to restart the computer every five minutes.

CAUSE

This problem may occur because of a race condition that causes the incorrect heap to be returned.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

    
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Oct-2004  19:58  5.2.3790.222      732,672  Ntdll.dll        
   15-Oct-2004  21:09  5.2.3790.222    2,407,936  Ntkrnlmp.exe
   15-Oct-2004  20:55  5.2.3790.222    2,064,896  Ntkrnlpa.exe     
   15-Oct-2004  20:55  5.2.3790.222    2,109,952  Ntkrpamp.exe
   15-Oct-2004  21:13  5.2.3790.222    2,208,256  Ntoskrnl.exe     
 

Windows Server 2003, 64-bit editions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   18-Oct-2004  20:50  5.2.3790.222    1,524,224  Ntdll.dll      IA-64
   15-Oct-2004  22:17  5.2.3790.222    5,605,888  Ntkrnlmp.exe   IA-64
   18-Oct-2004  20:58  5.2.3790.222      711,168  Wntdll.dll     x86
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB885889 kbAudITPRO