Other computers on the network cannot connect to your Windows XP Service Pack 2-based DHCP client computer after you log on to a network that is running the DHCP Server service (885865)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

SYMPTOMS

When you use a Microsoft Windows XP Service Pack 2 (SP2)-based computer to log on to a network that is running the DHCP Server service, your computer may not register the fully qualified domain name (FQDN) with the DNS server. Therefore, other computers on the network cannot connect with the Windows XP SP2-based computer.

Note This problem is more likely to occur when you use a virtual private network (VPN) and when you use a dial-up connection to connect to your network.

CAUSE

This problem occurs because the DHCP client in Windows XP SP2 uses the remote procedure call (RPC) mechanism to handle DHCP address change notifications. Earlier versions of Windows XP use a named pipe mechanism.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   27-Sep-2004  23:04  5.1.2600.2524     111,104  Dhcpcsvc.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug KB885865 kbAudITPRO