You cannot use infrared communications to transfer files on a computer that is running Windows XP Service Pack 2 (885855)



The information in this article applies to:

  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)

SYMPTOMS

If you run the Out-of-Box Experience (OOBE) and then restart your Microsoft Windows XP Service Pack 2 (SP2)-based computer, infrared communications may no longer work. You cannot use the infrared port to transfer data. If you delete the infrared device and then restart the computer, infrared communications work. However, if you restart the computer again, infrared communications no longer work.

Note When this problem occurs, you can still use infrared communications to print. Infrared printing is not affected by this problem.

CAUSE

This problem occurs because of a race condition that occurs at startup between the Irmon service and the Winlogon service. This problem is known to occur with certain portable computers.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Sep-2004  17:49  5.1.2600.2524      27,136  Irmon.dll     

WORKAROUND

To work around this problem, follow these steps to stop and restart the Irmon service:
  1. Click Start, point to All Programs, point to Administrative Tools, and then click Services.
  2. In the details pane, right-click Irmon, and then click Stop.
  3. After the Irmon service stops, right-click Irmon again, and then click Start.
  4. Quit Services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbWinXPsp3fix kbWinXPpresp3fix kbfix kbbug kbQFE kbHotfixServer KB885855 kbAudEndUser