No results are returned when you search for files or for folders over a slow network link in Windows Server 2003 or in Windows XP (885843)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you run a search for files or for folders across a slow network link in Microsoft Windows Server 2003 or in Microsoft Windows XP, the search result set is empty. This symptom occurs even though the files or the folders in question actually exist. Additionally, you receive the following message:Search is complete. There are no results to display. For example, you may experience this problem when you search a remote mapped drive over a wide area network (WAN) link.

CAUSE

This problem occurs because Windows incorrectly determines that the files or the folders in question are offline. Therefore, these files or folders are excluded from the search.

Notes
  • You may experience this problem on your Windows XP-based computer after you install the MS04-024 security update.
  • The MS04-024 security update is included with Windows XP Service Pack 2.
For more information about the MS04-024 security update, click the following article number to view the article in the Microsoft Knowledge Base:

839645 MS04-024: A vulnerability in the Windows shell could allow remote code execution

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 32-bit editions

   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   27-Sep-2004  23:08  6.0.3790.218    8,171,520  Shell32.dll 

Windows Server 2003 64-bit editions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   27-Sep-2004  23:09  6.0.3790.218   12,961,280  Shell32.dll    IA-64
   27-Sep-2004  23:08  6.0.3790.218    8,171,520  Wshell32.dll   x86

Windows XP hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must be running Windows XP Service Pack 1 or a later version of Windows XP.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Service Pack 1

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   20-Sep-2004  19:31  6.0.2800.1592      82,432  Fldrclnr.dll     
   20-Sep-2004  19:31  6.0.2800.1592   8,442,880  Shell32.dll      
   20-Sep-2004  19:31  5.1.2600.1592     700,928  Sxs.dll          
   20-Sep-2004  05:05  5.1.2600.1592     594,432  Xpsp2res.dll     
   20-Sep-2004  19:31  6.0.2800.1592     921,600  Comctl32.dll     
   20-Sep-2004  19:44                      1,812  Controls.man
   20-Sep-2004  19:44                        621  Comctl.man

Windows XP Service Pack 2

   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   20-Sep-2004  19:02  6.0.2900.2518   8,384,512  Shell32.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:3/15/2006
Keywords:kbHotfixServer kbWinXPpreSP3fix kbBug kbfix kbQFE kbWinServ2003preSP1fix KB885843 kbAudITPRO kbAudEndUser