Folder replicas may not be created when you run the Exchange Server 2003 Public Folder Migration tool (885826)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you use the Public Folder Migration tool (the pfMigrate tool) to replicate public folders or system folders between a Microsoft Exchange Server 5.5 computer and an Exchange Server 2003 computer, you may experience the following symptoms:
  • The the pfMigrate tool command script does not locate any public folders or system folders to replicate to the destination Exchange Server 2003 computer.
  • If you generate a log file when you use the pfMigrate tool, the log file may contain information that is similar to the following:

    Microsoft Exchange Public Folder Migration Tool
    
    <date and time>
    
    Source Server:	<SourceServerName>      Version 5.5 (Build 2653.23: Service Pack 4)
    Target Server:	<DestinationServerName>	Version 6.5 (Build 7226.6: Service Pack 1)
    WMI Server:	<DestinationServerName>
    
    Add Replica Mode in progress.
    Analyzing system folders under 'OFFLINE ADDRESS BOOK'
    
    Analysis of 0 folders with replica on '<SourceServerName>' completed.
    
    Analyzing system folders under 'EFORMS REGISTRY'
    
    Analysis of 0 folders with replica on '<SourceServerName>' completed.
    
    Analyzing system folders under 'SCHEDULE+ FREE BUSY'
    
    Analysis of 0 folders with replica on '<SourceServerName>' completed.
    
    0	folders without replica on '<SourceServerName>'.
    No folders were affected by the requested change.

This issue occurs even if the source server contains valid public folders and those public folders contain data.

Note The file name of the pfMigrate tool is pfMigrate.wsf.

CAUSE

This issue may occur if public folder information has not replicated successfully from the Exchange Server 5.5 site to the Exchange Server 2003 computer that the pfMigrate tool uses for Windows Management Instrumentation (WMI) communication.

To discover public folder replica information and system folder replica information from the source Exchange site, the pfMigrate tool depends on WMI to communicate with an Exchange Server 2003 computer. Therefore, Exchange Server 5.5 Directory Service replication, Active Directory Connector (ADC) replication, domain controller replication, and public folder hierarchy replication must be completed successfully before you use the pfMigrate tool to migrate public folder information.

Note Domain controller replication is also known as "backfill."

Depending on the complexity of your Exchange Server environment, the following processes may take a long time:
  • The complete replication of the public folder-specific attributes from Exchange Server 5.5 to the Active Directory directory service
  • The subsequent replication of the public folder hierarchy

RESOLUTION

To resolve this issue, verify that there is a configuration connection agreement, and then force replication of that connection agreement. To do this, follow these steps:
  1. Log on to the server where the Active Directory Connector is installed. Log on by using an account with at least local administrator permissions.
  2. Start the Active Directory Connector tool. To do this, click Start, point to Programs, point to Microsoft Exchange, and then click Active Directory Connector.
  3. Under Active Directory Connector Services, click Active Directory Connector (ServerName).
  4. In the right pane, verify that there is a configuration connection agreement to replicate content from a source server in the Exchange Server 5.5 site to Active Directory.
  5. Right-click the configuration connection agreement, and then click Replicate Now.

    Note If there is more than one configuration connection agreement, right-click each configuration connection agreement, and then click Replicate Now to force all the configuration connection agreements to replicate.
Note A public folder connection agreement is required if you use the pfMigrate tool in a cross-administrative-group scenario. If there is no public folder connection agreement, follow these steps:
  1. Run ADC Tools to configure or to repair your connection agreements. To run ADC Tools, start the Active Directory Connector tool, and then click ADC Tools.
  2. Follow the steps in the ADC Tools pane to configure your connection agreements.
  3. After you configure or repair your connection agreements, allow sufficient time for public folder replication to complete.
To verify that public folder information and system folder information have replicated successfully, follow these steps:
  1. Log on to the Exchange Server 2003 computer that you run the pfMigrate tool from. You must log on by using an account with at least local administrator permissions and with at least the Exchange View Only Administrator role assigned.
  2. Start the Exchange System Manager tool.
  3. Expand Folders, and then expand Public Folders.
  4. Right-click a public folder that is homed in the remote Exchange Server 5.5 site, and then click Properties.

    Note Select a folder that you expected the pfMigrate tool to replicate to the Exchange Server 2003 site. To view a system folder instead of a public folder, right-click Public Folders, and then click View System Folders.
  5. Click the Replication tab.
  6. View the entries in the Replicate content to these public stores list. Use one of the following procedures:
    • If this list contains one or more entries, you may have to wait for Exchange Server to finish replicating the public folder hierarchy to the Exchange Server 2003 computer that the pfMigrate tool uses for WMI communication. For additional information about how to specify the server that the pfMigrate tool uses for WMI, click the following article number to view the article in the Microsoft Knowledge Base:

      822895 Overview of the Public Folder Migration tool

    • If this list does not contain any entries, Active Directory Connector replication of the configuration information may not have completed successfully. In this scenario, you must perform additional troubleshooting steps of the Active Directory Connector configuration. For additional information about how to troubleshoot Active Directory Connector, see the "More Information" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

822895 Overview of the Public Folder Migration tool

For additional information about how to troubleshoot Active Directory Connector issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:

253841 Troubleshooting Active Directory Connector Replication issues

259396 How to set diagnostic logging for the Active Directory Connector

821828 How to troubleshoot issues with the Active Directory Connector Tools that are included with Exchange Server Deployment Tools and ADC Tools

For additional information about how to troubleshoot public folder replication, click the following article number to view the article in the Microsoft Knowledge Base:

842273 How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003


Modification Type:MinorLast Reviewed:11/7/2005
Keywords:kbtshoot kbprb KB885826 kbAudITPRO