One or more USB devices may not work after you start your Windows XP-based computer (885624)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you start a Microsoft Windows XP-based computer that has one or more universal serial bus (USB) devices attached, one or more of these USB devices may not work. You do not receive an error message in this scenario.

Note These USB devices may be attached either directly to USB ports on the computer or to an external USB bus-powered USB hub.

CAUSE

This issue may occur if either of the following conditions is true:
  • You have too many USB devices attached to the USB hub. This issue occurs because the combined sum of the power requirements of the USB devices is more than the available power that is provided by the hub.
  • You have a single USB device attached to a USB hub or to a USB port on the computer. Additionally, the single USB device requires more power than the power that is provided by the hub or by the port. This issue typically occurs if the following conditions are true:
    • The USB devices in question have the option of running with or without an AC power adapter.
    • You are using the device without the AC power adapter.
This issue may also occur if your computer uses an internal hub. For example, a portable computer may have a single USB bus and use an internal USB hub to provide two or more available USB ports on the computer. In this scenario, the available power from a single port may be less than expected if other USB devices are connected to the other USB ports that are on the same internal USB hub.

For example, if you start your computer, and you then connect additional USB devices to the computer until the total power consumption of the USB devices is more than the available power from the USB hub or port, one or more of the USB devices stop working. Then, you receive the following error message:
USB Hub Power Exceeded
Similarly, if you then restart your computer with the same configuration, the same USB device or devices do not work, and you do not receive an error message.

RESOLUTION

To resolve this issue, use one of the following methods, depending on your circumstances:
  • If the USB device is provided with an AC power adapter that you are not currently using, connect the AC power adapter to the USB device. When you do this, the power requirement for the USB device from the USB port or hub is greatly reduced.
  • If the hub is provided with an AC power adapter that you are not currently using, connect the AC power adapter to the hub. Typically, you can use a USB hub with or without an AC power adapter. There is more power available from a USB hub when the hub is powered by the AC power adapter.
  • If you are using a passive, or unpowered, USB hub, replace the passive USB hub with an active, or powered, hub.
  • Determine which USB device is not working or is causing the issue, and then connect that device directly to a USB port on the computer.

    To determine which device is causing the issue, follow these steps:
    1. Disconnect all the devices from the USB hub.
    2. Restart the computer.
    3. Connect the devices one at a time until you receive the following error message:
      USB Power Exceeded
      Try different combinations of connected devices to determine the most effective configuration.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:

310591 "USB Power Exceeded" error message when connecting USB devices


Modification Type:MinorLast Reviewed:5/26/2006
Keywords:kbtshoot kberrmsg KB885624 kbAudEndUser