The Exchange Server Migration Wizard crashes when it migrates information from a Lotus Notes mailbox to an Exchange Server 2003 organization (885455)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you run the Exchange Server Migration Wizard to migrate information from a Lotus Notes mailbox to your Microsoft Exchange Server 2003 organization, the Exchange Server Migration Wizard unexpectedly quits (crashes).

In this scenario, no Warning event or Error event is logged, and you do not receive a Dr. Watson error message.

CAUSE

This problem may occur if the following conditions are true:
  • You import Lotus Notes information that contains a recurring meeting item.
  • That recurring meeting item does not have an ending date.

    Note Lotus Notes uses the value -1 to designate a recurring meeting that does not have an ending date. This value is equivalent to hexadecimal FFFF. In this scenario, the Exchange Server Migration Wizard interprets the recurring meeting as having an ending date of hexadecimal FFFF for the day, hexadecimal FFFF for the month, and hexadecimal FFFF for the year.
The Exchange Server Migration Wizard interprets each of these hexadecimal values to be 65535. Each of these values are much larger than either the four-digit value that the Exchange Server Migration Wizard expects for the year entry or the two-digit value that the Exchange Server Migration Wizard expects for the day entry and for the month entry.

The Exchange Server Migration Wizard expects the date to be in the following format:

DD-MM-YYYY

However, the Exchange Server Migration Wizard interprets this resultant date to have the following format:

65535-65535-65535

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, Microsoft Exchange Server 2003 Service Pack 1 (SP1) is required to install this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Oct-2004  00:45  6.5.7232.48     4,460,032  Mlmig32.dll      
   29-Oct-2004  00:41  6.5.7232.48        59,392  Mlmignts.dll    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbBug kbExchange2003preSP1fix KB885455 kbAudITPRO