A 35-second delay occurs when you delete a file that is located on a network share in Windows Server 2003 (885451)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

For a Microsoft Windows XP version of this article, see 811492.

SYMPTOMS

When you use Windows Explorer on a Microsoft Windows Server 2003-based client computer to delete a file that is located on a network share, you experience a delay of approximately 35 to 40 seconds before the file is deleted.

A network trace of the problem shows the following error message for the server message block (SMB) Delete request:
Delete file - NT Error, System Error, Code= (67) STATUS_SHARING_VIOLATION

CAUSE

This problem is caused by a pseudo-deadlock condition that exists when the opportunistic lock (oplock) Break request is received by the client computer. When the client computer receives the Break request, it cannot process the request because it is already waiting on the Delete request. The server cannot process the Delete request until the oplock on the file is released. The pseudo-deadlock condition exists until the time-out value that is set in the OplockBreakWait registry entry on the server expires. By default, the OplockBreakWait time-out value is set to 35 seconds.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix that is documented in the following article in the Microsoft Knowledge Base:

811492 It may take 35 seconds to delete files over the network

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

   Date         Time   Version       Size     File name
   -----------------------------------------------------
   13-Sep-2004  19:19  5.2.3790.210  395,264  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194  158,208  Rdbss.sys

Windows Server 2003, 64-bit editions

   Date         Time   Version       Size       File name
   -------------------------------------------------------
   13-Sep-2004  19:18  5.2.3790.210  1,123,328  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194    464,896  Rdbss.sys

WORKAROUND

To work around this problem, disable opportunistic locking on either the Windows Server 2003-based client computer or the server where the network share is located. For additional information about how to disable opportunistic locking, click the following article number to view the article in the Microsoft Knowledge Base:

296264 Configuring opportunistic locking in Windows

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies To" section.

MORE INFORMATION

For additional information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB885451 kbAudITPRO