Nothing happens in Internet Explorer 6 when you click a hyperlink on a Web page that was created in Microsoft Excel (885439)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Starter Edition
    • Microsoft Windows XP Tablet PC Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario:
  • You create a Web page that contains hyperlinks in Microsoft Excel.
  • You save the page in Excel as a Web page that has an .html extension .
  • You publish the page.
  • You open the Web page in Microsoft Internet Explorer 6.
In this scenario, nothing happens when you click a hyperlink on the Web page.

CAUSE

This problem occurs after you install one of the following service packs:
  • Windows Server 2003 Service Pack 1 (SP1)
  • Windows XP Service Pack 2 (SP2)

RESOLUTION

Hotfix information

Microsoft Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites There are no prerequisites to apply this hotfix. Restart requirement You must restart your computer after you apply this hotfix. Hotfix replacement Information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003
File nameFile versionFile sizeDateTime
Mshtml.dll6.0.3790.27573,153,92026-Jul-200617:33

Microsoft Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites There are no prerequisites to apply this hotfix. Restart requirement You must restart your computer after you apply this hotfix. Hotfix replacement Information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP
File nameFile versionFile sizeDateTime
Mshtml.dll6.0.2900.29613,057,66426-Jul-200612:40

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

How to enable the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click to select the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_EXPAND_URL_FOR_ZONE_CHECK_KB885439

  3. After you select the key that is specified in step 2, point to New on the Edit menu, and then click DWORD Value.
  4. Type IExplore.exe, and then press ENTER.
  5. Right-click IExplore.exe, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.
For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/11/2006
Keywords:kbWinServ2003preSP2fix kbExpertiseBeginner kbWinXPpreSP3fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB885439 kbAudEndUser