FIX: SNA Manager does not display the correct remote APPC LU session status if you update the SNA Manager MMC snap-in after APPC sessions are re-established in Host Integration Server (885429)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft Host Integration Server 2004

SYMPTOMS

In Microsoft Host Integration Server 2000 and Host Integration Server 2004, SNA Manager does not display the correct Advanced Program-to-Program Communications (APPC) session status when you view a remote APPC logical unit (LU). This problem occurs if the SNA Manager MMC snap-in is updated after APPC sessions are reestablished.

When the problem occurs, it seems that no active sessions exist over the remote APPC LU that is being viewed in SNA Manager. If you change the focus in SNA Manager to view the local APPC LU that is partnered with the remote APPC LU, SNA Manager shows that active sessions exist over the remote APPC LU.

CAUSE

This problem occurs because the Host Integration Server management components do not correctly update the remote APPC LU status after the SNA Manager MMC snap-in is update and the update occurs after APPC sessions are reestablished.

RESOLUTION

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   21-Oct-2004  23:16  5.0.0.1006  114,960  Mngbase.dll      
   21-Oct-2004  23:16  5.0.0.1006  114,960  Mngsna.dll       
   21-Oct-2004  23:16  5.0.0.1006  102,672  Mngagent.exe     
   21-Oct-2004  23:16  5.0.0.1006  102,672  Mngcli.exe       
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size    File name
   ----------------------------------------------------
   22-Oct-2004  22:00  6.0.1908.0  82,432  Mngagent.exe     
   22-Oct-2004  22:00  6.0.1908.0  88,064  Mngbase.dll      
   22-Oct-2004  22:00  6.0.1908.0  81,920  Mngcli.exe       
   22-Oct-2004  22:00  6.0.1908.0  95,744  Mngsna.dll
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

WORKAROUND

To work around this problem, stop and then restart the SNA MngAgent service. When you do this, SNA Manager will display the correct status for APPC sessions when you view a remote APPC LU.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

MORE INFORMATION

Steps to reproduce the problem

  1. Open the SNA Manager MMC snap-in.
  2. Expand the Host Integration Server subdomain tree, and choose a configured remote APPC LU.
  3. Start an APPC application that will establish an APPC session by using the remote APPC LU that you chose in step 2. Do this so the correct status appears for an active APPC session.
  4. Stop the SNA Server service that the chosen remote APPC LU is using to communicate with the IBM host system.
  5. After the SNA Server service has successfully stopped, restart the SNA Server service.
  6. Start the APPC application again to establish an APPC session by using the same remote APPC LU.
  7. Press F5 to update the SNA Manager MMC snap-in.

    The active APPC sessions that previously appeared when you viewed the remote APPC LU no longer appear even though they are still active.

    If you change the focus in SNA Manager to the local APPC LU that the APPC sessions are also using, the correct status of the APPC sessions will appear.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug KB885429 kbAudDeveloper