SYMPTOMS
When you try to upload a large file to a File Transfer Protocol (FTP) server that is published through a Microsoft Internet Security and Acceleration (ISA) Server 2000 computer, the transfer unexpectedly quits after 60 seconds.
Additionally, you receive the following error message:
Connection reset by peer.
CAUSE
This problem occurs if the following conditions are true:
- The ISA Server 2000 computer is configured to replace the source address of incoming requests with the source address of the ISA Server 2000 computer. Therefore, the packets that are sent to the published FTP server have the source address of the ISA Server 2000 computer.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
311777
How to enable translating client source address in server publishing
- The Enable IP routing check box is selected on the ISA Server 2000 computer.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
279347
Enable IP routing on ISA Server to increase performance
In this scenario, the timer is supposed to close the internal FTP secondary connection if the connection is idle for 60 seconds. Instead, the timer incorrectly closes the
active secondary connections.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Security and Acceleration Server 2000 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
To install this hotfix, you must have ISA Server 2000 Service Pack 2 installed.
For additional information about how to obtain ISA Server 2000 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
313139
How to obtain the latest Internet Security and Acceleration Server 2000 service pack
Restart requirement
You do not have to restart your computer to install this hotfix. However, the hotfix package will restart all ISA Server services during the installation of this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
--------------------------------------------------------
28-Sep-2004 09:43 3.0.1200.407 307,192 Wspsrv.exe