"Cannot Play Video" error message after you switch from full-screen mode to PIP mode on a Windows XP Media Center Edition-based computer (885402)



The information in this article applies to:

  • Microsoft Windows XP Media Center Edition

SYMPTOMS

When you run Microsoft Windows XP Media Center Edition and switch from full-screen video playback to Picture in Picture (PIP) playback, or vice versa, you may receive the following error message:
Cannot Play Video
You may also be decremented multiple times for subscribed content when you switch from one screen to another.

CAUSE

This behavior occurs because a service provider can write a custom Microsoft Windows Media Services Authorization plug-in to enforce a "play once" or "play a certain number of times" subscription model.

Note For more information about the "play once" and the "play a certain number of times" subscription models, please see the More Information section.

RESOLUTION

When you purchase or select video or audio content, consider a time-based option or a purchase to own option that would give you more flexibility with the ways that you can view the content. Make sure that you discuss this with your vendor for additional options.

STATUS

This behavior is by design.

MORE INFORMATION

A "play once" or a "play a certain number of times" subscription model limits the number of times an end user can view a video. In some client programs, such as Windows XP Media Center Edition, when you switch from full-screen mode to windowed mode while you are watching the video, the client will create a new connection to the server to retrieve content.

Depending on the logic of the Windows Media Services Authorization plug-in, the new connection may decrement the number of plays that you have left. Additionally, if you exhaust your play count, the new connection may not be able to render the content in Microsoft Windows Media player.

When you use Windows Media Player, you may experience the same behavior when you close a stream or when you switch to another URL and then try to come back and play the same piece of content.

Modification Type:MajorLast Reviewed:1/4/2005
Keywords:kbtshoot kbprb KB885402 kbAudEndUser