A user cannot sign in to Live Communications Server after you configure their user account with the SIP URI of a deleted user account (885342)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003

SYMPTOMS

After you enable a user account for Live Communications, that user cannot sign in to their Microsoft Office Live Communications Server 2003 Home Server. In this scenario, you experience both the following symptoms:
  • When the user tries to sign in to Live Communications Server, that user is prompted for credentials. If that user enters his or her credentials and then tries to sign in, that user receives the following error message:
    Signing in to SIP Communications Service failed because the sign-in name, username, or password is incorrect, or the authentication service is not compatible with this version of the program. If you have signed in correctly and the problem persists, contact your network administrator.
  • The following event appears in the Application log on the Live Communications Server Home Server computer:Event Source: Live Communications Active Directory Connector
    Event Category: (1009)
    Event ID: 26
    Date: date
    Time: time
    Type: Warning
    User: N/A
    Computer: ComputerName
    Description: Tried to change an existing user to have a URI of sip:user1@example.com, but the URI is already being used in the database. Use a URI that isn't already taken. The DN of the user whose URI we tried to change is: CN=user3,CN=Users,DC=EXAMPLE,DC=COM
    This update came from the naming context:
    DC=EXAMPLE,DC=COM

CAUSE

This problem occurs if all the following conditions are true:
  • You have a user (User A) in the Active Directory directory service who is enabled for Live Communications Server.
  • User A has been added to the contact list of another Live Communications Server user.
  • You remove User A from Active Directory.
  • You assign User A's Session Initiation Protocol (SIP) uniform resource identifier URI to another user for Live Communications Server.
This problem occurs because references to the removed user remain in the Live Communications Server 2003 database after the user is removed from Active Directory.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   ----------------------------------------
   18-Aug-2004  21:18  4,382   LiveComm-KB885342-x86-USA.sql

Hotfix installation information

You must install this hotfix on each of your Live Communications Server Home Server computers. This hotfix causes Live Communications Server to remove references to a user from the Live Communications Server database when you remove a user from Active Directory. After you install this hotfix, you can re-use SIP URIs in Live Communications Server.

Important This hotfix resolves this problem only for users whose SIP URI you modify after you install this hotfix. For user accounts that you currently experience this problem with, follow the steps that are described in the "Workaround" section.

Note No program exists to remove this hotfix.

WORKAROUND

To work around this problem, manually remove the account information that corresponds to the deleted Active Directory user account from the Microsoft Data Engine (MSDE) database. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following command, and then press ENTER, where user@domain is the sign-in name of the removed user account:

    OSQL -S (local)\rtc -d rtc -E -Q "exec RtcDeleteResource N'user@domain'"

    Note The OSQL command must be run on every Live Communications Server computer in the forest.
  3. Temporarily assign a new bogus SIP URI to the user account that you experience this problem with. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Live Communications Server.
    2. Expand Servers, expand your Live Communications Server computer, and then click Users.
    3. In the right pane, right-click User@domain.com, and then click Properties. (User@domain.com is the re-used URI.)
    4. In the SIP URI box, type usertempURI@domain.com after sip:. Replace usertempURI with a bogus or dummy value. This temporary value forces the user account to be re-synchronized by all the Live Communications Server computers in the forest.
    5. Click Apply, wait several minutes to make sure that all the Live Communications Server computers synchronize this change, and then restore the user account SIP URI to its previous value. For example, type User@domain.com in the SIP URI box.
    6. Click Apply, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

871023 Using the Windows Messenger 5.0 debug log to troubleshoot sign-in failures in Live Communications Server 2003


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kberrmsg ATdownload kbBug kbfix kbprb KB885342 kbAudITPRO