A race condition occurs when more than one Sender thread tries to process the same send request at the same time in SMS 2003, SMS 2003 SP1, and SMS 2.0 SP5 (885278)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP1
  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

The Sender component in Microsoft Systems Management Server (SMS) 2.0 Service Pack 5 (SP5) may experience a race condition if two Sender threads try to process the same send request (.srq file) at the same time. When this race condition occurs, you may experience one or more of the following symptoms:
  • An error that is similar to the following is logged in the SMS\Logs\sender.log:
    Cannot create/open the remote file \\SMSServer\SMS_SITE\2_K1Q0P0.PCK, Win32 error = 32The Sender component may also mark the send request as invalid.
  • The two Sender threads manage the send request and send the same data two times.
  • The first Sender thread exits correctly, but the second thread fails.
  • The second Sender thread exits correctly, but the first thread fails. The send request is flagged as invalid (SREQ_STATUS_INVALID).
The orphaned or invalid send requests may prevent the Scheduler component from processing fan-out routing requests (.rtr files).

You may experience these symptoms on any SMS site server in the hierarchy. However, these symptoms typically occur on the central site of a large SMS hierarchy.

CAUSE

This problem occurs because the Sender component does not synchronize the sender threads before it processes send requests.

RESOLUTION

SMS 2003 service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

SMS 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   ----------------------------------------------------------------------------
   15-Apr-2005  15:33  2.50.2726.164  628,968  Sms2003-rtm-kb885278-x86-enu.exe
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   25-Dec-2003  16:20  2.50.2726.164  974,848  Baseobj.dll
   25-Dec-2003  16:15  2.50.2726.163  184,320  Ddm.dll
   25-Dec-2003  13:30  2.50.2726.154   40,960  Smsse.dll
   25-Dec-2003  13:30  2.50.2726.154   40,960  Smsse.dll

SMS 2.0 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Oct-2004  21:09  2.0.1493.5196     984,808  Sms2.0-sp5-kb885278-x86-enu.exe
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   01-Oct-2004  11:46                     13,167  Filemap.ini
   20-Feb-2004  09:03  2.0.6.7           355,242  Smsupdate.exe    
   25-Feb-2003  15:00  2.0.1493.5196     968,800  Baseobj.dll      
   25-Feb-2003  14:30  2.0.1493.5190     176,016  Ddm.dll          
   06-Aug-2000  00:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  01:05  2.0.1493.5011     855,312  Preinst.exe
This hotfix adds thread synchronization to the send-request selection function.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information about standard terminology that is used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS2003spfix kbSMS2003bug kbSMSSender kbSMSDistribution kbSMS200preSP6fix kbScheduler kberrmsg kbPerformance kbSoftwareDist kbfix KB885278 kbAudITPRO