The Microsoft Search service does not work in SharePoint Portal Server 2003 (885265)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003


SYMPTOMS

When you try to start the Microsoft Search service (Mssearch.exe) in Microsoft Office SharePoint Portal Server 2003, the Microsoft Search service does not work.

When you view the Application log in Event Viewer on the search server, you see events that are similar to the following:
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Search service
Event ID: 7051
Date:  Date
Time:  Time
User:  N/A
Computer: Computer_Name
Description: Index propagation to search server <Computer_Name (IP_Address)> was not accepted. Context: http://Server/ Application, KBCatalog Catalog Details:  The content index server cannot update or access information because of a database error.  Stop and restart the search service.  If the problem persists, reset and recrawl the content index.  In some cases it may be necessary to delete and recreate the content index.   (0x8004117f) For more information visit http://www.microsoft.com/servers/redirect/contentredirect2.asp For more information, see Help and Support Center at http://support.microsoft.com.
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Content index server
Event ID: 7039
Date:  Date
Time:   Time
User:  N/A
Computer: Computer_Name
Description: The content index cannot be loaded. Context: http://Server / Application, KBCatalog Catalog Details:   (0x8004117f - The content index server cannot update or access information because of a database error.  Stop and restart the search service.  If the problem persists, reset and recrawl the content index.  In some cases it may be necessary to delete and recreate the content index.) For more information visit http://www.microsoft.com/servers/redirect/contentredirect2.asp For more information, see Help and Support Center at http://support.microsoft.com.
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Content index server
Event ID: 7037
Date:  Date
Time:   Time
User:  N/A
Computer: Computer_Name
Description: The property store was not initialized. Context: http://Server / Application, KBCatalog Catalog Details:  The content index server cannot update or access information because of a database error.  Stop and restart the search service.  If the problem persists, reset and recrawl the content index.  In some cases it may be necessary to delete and recreate the content index.   (0x8004117f) For more information visit http://www.microsoft.com/servers/redirect/contentredirect2.asp For more information, see Help and Support Center at http://support.microsoft.com.
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Search service
Event ID: 7043
Date:  Date
Time:   Time
User:  N/A
Computer: Computer_Name
Description: The index cannot be loaded. Context: http://Server/ Application, Portal_Content Catalog Details:  The content index server cannot update or access information because of a database error.  Stop and restart the search service.  If the problem persists, reset and recrawl the content index.  In some cases it may be necessary to delete and recreate the content index.   (0x8004117f) For more information visit http://www.microsoft.com/servers/redirect/contentredirect2.asp For more information, see Help and Support Center at http://support.microsoft.com.
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Search service
Event ID: 9000
Date:  Date
Time:   Time
User:  N/A
Computer: Computer_Name
Description: The search service cannot open the Jet property store. Details:  The content index server cannot update or access information because of a database error.  Stop and restart the search service.  If the problem persists, reset and recrawl the content index.  In some cases it may be necessary to delete and recreate the content index.   (0x8004117f) For more information visit http://www.microsoft.com/servers/redirect/contentredirect2.asp For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs if the Ese.dll file does not load correctly, and the Esent.dll file is loaded instead by the Mssearch.exe process. This causes the search functionality to stop working.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft Office SharePoint Portal Server 2003 Service Pack 2.

To resolve this problem, obtain the latest service pack for SharePoint Portal Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889380 How to obtain the latest service pack for SharePoint Portal Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Office SharePoint Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart information

You must restart the Microsoft Search service after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Sep-2004  16:09  11.0.5716.29       91,848  Mssmsg.dll
   13-Sep-2004  16:09  11.0.5716.29      521,928  Mssph.dll
   13-Sep-2004  16:09  11.0.5716.29    2,272,456  Mssrch.dll
   13-Sep-2004  16:09  11.0.5716.29    1,681,608  Tquery.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in SharePoint Portal Server 2003 Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbSharePtPortalSvr2003SP2fix kbHotfixServer kbQFE kbSharePtPortalSvr2003preSP2fix kbBug kbSharePtPortalSvr2003preSP1fix kbfix KB885265 kbAudITPRO