The Host Integration Server 2004 Transaction Integrator (TI) Manager does not open after the Windows Server name is changed (885003)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

When the Microsoft Windows Server name is changed after Microsoft Host Integration Server 2004 Transaction Integrator (TI) has been installed and configured, the TI Manager does not open and you receive the following error messages:
An error has occured in CHipTree::OnItemExpand
An unexpected error has occured in function CHipTree::OnItemExpand


An error has occured in CHipTree::OnInitView
An unexpected error has occured in function CHipTree::OnInitView
Note The word "occurred" is spelled incorrectly in these error messages.

CAUSE

This problem occurs because the MSHIS60_HIP database has not been updated with the new server name.

RESOLUTION

To resolve this issue, you must manually update the database that TI uses to retrieve the server name. To do this, follow these steps:
  1. Start Microsoft SQL Server Enterprise Manager.
  2. Click the SQL Server-based server that is used by TI.
  3. Expand Databases, expand the MSHIS60_HIP database, and then click the Computers table.
  4. Click Action, point to Open Table, and then click Return all rows.
  5. The old name of the Windows Server appears in the Name column. Replace this value with the updated Windows Server name.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:9/9/2004
Keywords:kbtshoot kbprb KB885003 kbAudDeveloper