You receive a "Cannot retrieve list of objects due to a WMI provider failure" error message in BizTalk Server 2004 when you try to examine the properties of any Send Port or Receive Port (884980)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Standard Edition

SYMPTOMS

When you try to examine the properties of any Send Port or Receive Port in Microsoft BizTalk Server 2004, you receive the following error message:
Cannot retrieve list of objects due to a WMI provider failure.

CAUSE

This problem occurs when the BizTalk Server Administration Console connects to the wrong Enterprise Single Sign-On (SSO) server.

RESOLUTION

To resolve this issue, enter the correct name of the Enterprise SSO server. To do this, follow these steps:
  1. Start BizTalk Server Administration.
  2. In the BizTalk Server Administration Console window, right-click Microsoft BizTalk Server 2004, and then click Properties.
  3. In the Enterprise Single Sign-On server name box, type YourServer where YourServer is the name of your Enterprise SSO server, and then click OK.

MORE INFORMATION

Steps to reproduce the behavior

  1. Start BizTalk Server Administration.
  2. In the BizTalk Server Administration Console window, right-click Microsoft BizTalk Server 2004, and then click Properties.
  3. In the Enterprise Single Sign-On server name box, type NotYourServer where NotYourServer is not the name of your Enterprise SSO server, and then click OK.
  4. In the BizTalk Server Administration Console window, click Send Ports.

    You receive the error message that is mentioned in the "Symptoms" section.
For more information about Microsoft BizTalk Server 2004, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/26/2006
Keywords:kbbiztalk2004-2006swept kbtshoot kbprb KB884980 kbAudITPRO kbAudDeveloper