The Virtual Server service quits unexpectedly on a computer with multiple CPUs that is running Virtual Server 2005 (884869)



The information in this article applies to:

  • Microsoft Virtual Server 2005, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition

SYMPTOMS

If you run Microsoft Virtual Server 2005, the Virtual Server service unexpectedly stops. After the Virtual Server service stops, all your running virtual machines also stop. This symptom occurs if you run Virtual Server 2005 on a computer that has multiple CPUs and the CPUs have a fourth level of cache. A fourth level of cache is known as an L4 cache.

CAUSE

This problem occurs because of an access violation in the Virtual Server service.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Virtual Server 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   --------------------------------------------------------------------------------------
   14-Sep-2004  18:34                558,033  Docscomh
   14-Sep-2004  18:34                  7,974  Docscomlib
   14-Sep-2004  18:34  1.1.465.10     72,424  En_usmsgdll
   14-Sep-2004  18:34  1.1.465.10    199,408  Interopasm
   14-Sep-2004  18:34  1.1.465.10     72,424  Virtualserverlogmessages
   14-Sep-2004  18:34  1.1.465.10    137,984  Vmh.d7359402_6295_464f_92bb_a4144358e695
   14-Sep-2004  18:34  1.1.465.10    151,768  Vmmsys.3d2f911e_a60a_4c07_8f7d_5306dc073e9a
   14-Sep-2004  18:34  1.1.465.10    363,256  Vmrcclientapp
   14-Sep-2004  18:34  1.1.465.10  2,976,480  Vssrvc
   14-Sep-2004  18:34  1.1.465.10  1,669,872  Vswebapp
   14-Sep-2004  18:34                225,234  Vswebappactivexcab

Hotfix installation information

When you extract the hotfix package, the Qfe_884689_installation.doc file is extracted. Follow the instructions in the Qfe_884689_installation.doc file to install this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE KB884869 kbAudITPRO