HTML e-mail messages lose their formatting when you use the Exchange Mailbox Merge program to migrate .pst files to Exchange Server 2003 mailboxes (884849)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

When you use the Microsoft Exchange Mailbox Merge program (Exmerge.exe) to migrate Microsoft Outlook Personal Folders (.pst) files to mailboxes on your Microsoft Exchange Server 2003 computer, many of the HTML e-mail messages lose their HTML formatting during the migration process. For example, when you view the e-mail messages in your Exchange 2003 mailbox, the message text is rendered in plain text format.

CAUSE

This problem occurs because the Exchange 2003 version of the Mapi32.dll file incorrectly copies the body HTML property as a string instead of as a binary property.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must be running Exchange Server 2003 Service Pack 1 (SP1). For additional information about how to obtain Exchange Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer to install this hotfix. However, the following Exchange services are automatically restarted during the hotfix installation:
  • Microsoft Exchange Site Replication Service
  • Microsoft Exchange Management
  • Microsoft Exchange MTA Stacks
  • Microsoft Exchange Event
  • Microsoft Exchange Information Store
  • Microsoft Exchange System Attendant

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Sep-2004  18:19  6.5.7232.39       635,392  Mapi32.dll    

WORKAROUND

To work around this problem, import the .pst file directly into Outlook by using the Outlook client program.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbCoExistMigration kbExchange2003preSP2fix kbfix kbBug KB884849 kbAudITPRO