FIX: You cannot process a signed RosettaNet message with the BizTalk Server Accelerator for RosettaNet 2.0 and an "Event ID 324" error message is logged in the application event log (884556)



The information in this article applies to:

  • Microsoft BizTalk Server Accelerator for RosettaNet, version 2.0

SYMPTOMS

When you try to process a signed RosettaNet message with the Microsoft BizTalk Server Accelerator for RosettaNet 2.0, you are unsuccessful and the following error message is logged in the application event log:
Event Type: Error
Event Source: BizTalkServer
Event Category: Document Processing
Event ID: 324
Description:
An error occurred in BizTalk Server. Details: ------------------------------ [0x013a] The XML document could not be parsed on line: LineNumber, position: ColumnPosition for the following reason: "Whitespace is not allowed at this location. "

[0x1730] Suspended Queue ID: "{DC60C6D5-CDE9-412B-9BB7-ACC003E23235}"

[0x80004005] Unspecified error Note LineNumber is the line number and ColumnPosition is the column position.

CAUSE

This problem occurs when the following conditions are true:
  • The RossettaNet message is signed with a certificate.
  • The subject field of the certificate contains characters that are not allowed in a well-formed XML document and these characters must be escaped.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size     File name
   ---------------------------------------------------------
   27-Aug-2004  18:46  3.0.577.0  116,224  Biztalkparser.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the BizTalk Accelerator for RosettaNet 2.0, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbBizTalk2004preSP1fix kbfix kbBug kbQFE kbprb kbHotfixServer KB884556 kbAudDeveloper kbAudITPRO