FIX: The receipt is not successful when you use the Microsoft BizTalk Adapter 2.0 for mySAP Business Suite to receive an IDOC in BizTalk Server 2004 (884553)



The information in this article applies to:

  • Microsoft BizTalk Adapter 2.0 for mySAP Business Suite
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Standard Edition

SYMPTOMS

When you use the Microsoft BizTalk Adapter 2.0 for mySAP Business Suite to receive an Intermediate Document (IDOC), the receipt is not successful.

When you run the asynchronous Request for Comments (RFC) error log command, also known as the SM58 command, on the SAP system, you receive the following error message:
TARGET_METHOD_EXCEPTION raised by external server
Note The RFC TCP/IP destination cannot connect to the adapter until the related Microsoft BizTalk Server 2004 host instance is restarted.

CAUSE

The problem occurs when the control record of the IDOC contains double-byte character set (DBCS) characters.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next BizTalk Adapter 2.0 for mySAP Business Suite service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Sep-2004  02:43  2.0.318.0          64,200  Sapreceiver.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Microsoft BizTalk Server 2004, visit the following Microsoft Web site: For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbprb KB884553 kbAudDeveloper kbAudITPRO