FIX: APPC and Common Programming Interface for Communications (CPI-C) applications may stop responding if the SNA Server service becomes unavailable (884550)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft Host Integration Server 2004

SYMPTOMS

APPC and Common Programming Interface for Communications (CPI-C) applications may stop responding (hangs) if the SNA Server service (Snaservr.exe) that the application is communicating through becomes unavailable.

CAUSE

The underlying Microsoft Host Integration Server dynamic address module (DMOD) client/server interface will try to establish a connection to another SNA Server service if it loses its connection to the SNA Server service that it was previously communicating with. If the connection to another SNA Server service fails and the DMOD retries the connection more than 32 times, an access violation occurs in the APPC library (Wappc32.dll). Any subsequent APPC or CPI-C calls that are issued by the application do not complete after the access violation occurs. Therefore, the APPC or CPI-C application stops responding.

RESOLUTION

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size c   File name
   ---------------------------------------------------
   20-Aug-2004  16:38  5.0.0.996  229,648  Wappc32.dll

Host Integration Server 2004

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ----------------------------------------------------
   20-Aug-2004  17:36  6.0.1903.0  163,328  Wappc32.dll

				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbHostIntegServ2000preSP2fix kbfix kbbug KB884550 kbAudDeveloper