An attachment that has an encoded file name that contains Japanese Industry Standards (JIS) characters may be corrupt in Exchange 2000 or in Exchange 2003 (884477)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

SYMPTOMS

When you receive an attachment in an e-mail message that has an encoded file name that contains Japanese Industry Standards (JIS) characters, the file name may be corrupt.

CAUSE

This issue occurs when the following conditions are true:
  • You are running Microsoft Exchange 2000 Server.
  • The attachment's file name starts with an ASCII string. However, the file name switches to JIS in the middle of the file name.
  • There is a 0x5c character in the encoded Japanese Industry Standards characters.

RESOLUTION

Exchange Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Exchange 2000 Server

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Sep-2004  08:44  6.0.6617.10       262,144  Exmime.dll       
				
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3(SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.
This problem was first corrected in Microsoft Exchange Server 2003 Service Pack 2.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbexchTRANSPORT kbfix kbbug kbHotfixServer kbQFE KB884477 kbAudDeveloper kbAudEndUser kbAudITPRO