Some of your SMTP e-mail messages may remain in your outgoing mail queues with a status of 'Unable to bind to the destination server in DNS' in Exchange 2000 Server (884421)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

In Microsoft Exchange 2000 Server, some of your SMTP e-mail messages may remain in your outgoing mail queues in Exchange System Manager. Additionally, if you view the properties of a message in Queue Viewer, the Details tab shows the following status for the message:Unable to bind to the destination server in DNS.

Additionally, you may see events that are similar to the following in the event log:Event ID 4000
Source: SMTPSVC
Type: Warning
Description: Unable to bind to the destination server in DNS.

This symptom may occur even if you add an SMTP connector and set it to forward e-mail messages to the address of a smart host.

CAUSE

This issue may occur if either of the following conditions is true:
  • External Domain Name System (DNS) servers are configured incorrectly for the default SMTP virtual server in Exchange. You can view the configuration settings on the Delivery tab in the Advanced Delivery dialog box of the default SMTP virtual server.
  • The external DNS servers that are specified for the default SMTP virtual server are no longer available.


This problem can also be caused by the Secure cache against pollution option in Microsoft Windows 2000 DNS. If the Secure cache against pollution option is enabled, it can prevent the DNS server from following up DNS referrals.

Important Do not disable the Secure cache against pollution option. Refer to the article in the "Workaround" section to deal with this issue.

WORKAROUND

To work around this issue, remove the external DNS server references in Exchange System Manager, and then restart Microsoft Internet Information Services (IIS).

To remove the external DNS server references, follow these steps:
  1. Start Exchange System Manager.
  2. If administrative groups are enabled, expand Administrative Groups, and then expand First Administrative Group.

    If administrative groups are not enabled, go directly to step 3.
  3. Expand the Servers container, and then expand the Your_Server_Name container.
  4. Expand the Protocols container, and then expand the SMTP container.
  5. Right-click Default SMTP Server, and then click Properties.
  6. Click the Delivery tab, and then click Advanced.
  7. Click Configure, and then click the first entry in the External DNS list.
  8. Click Remove.
  9. Remove each remaining entry from the External DNS list.
  10. Click OK three times.
  11. Quit Exchange System Manager.
To restart IIS, follow these steps:
  1. Open the Services snap-in.
  2. Right-click the IIS Admin Service, and then click Restart.
  3. In the Restart Other Services dialog box, click Yes to restart the dependency services.
  4. Close the Services snap-in.

If the symptoms still persist after you remove the external DNS server references in Exchange System Manager, perform the steps that are described in the following article to resolve this issue.

313264 DNS server referral chasing when the SecureResponses option is enabled

REFERENCES

For additional information about configuring SMTP in Exchange 2000, click the following link to download the Configuring SMTP in Microsoft Exchange 2000 Server book.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the SMTPConfigE2k.exe package now.
For information about configuring SMTP in Microsoft Exchange Server 2003, click the following link to download the Exchange Server 2003 Transport and Routing Guide.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the Ex2K3_Transport_Routing_Guide.exe package now.
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

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Modification Type:MajorLast Reviewed:12/3/2004
Keywords:kbtshoot kbprb KB884421 kbAudITPRO