FIX: The audio is temporarily lost for some items in the playlist when you play streaming content by using the RTSP protocol (884267)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Server 2003
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series SDK
  • Microsoft Windows Media Player 10
  • Microsoft Windows Media Player 10 SDK

SYMPTOMS

When you play streaming content from a client-side playlist and the content originates on a Microsoft Windows Media Player 9 Series, the audio is temporarily lost for some items in the playlist in Windows Media Player.

CAUSE

This problem occurs because a timing issue in the Windows Media Player causes 1 or 2 audio packets not to be rendered by the player. This problem occurs when you use the Real Time Streaming Protocol (RTSP), the Fast Cache feature, and client-side playlists.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Media Player release that contains this hotfix.

Windows Media Player 9 Series for Windows XP

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsXP-KB884267-x86-ENU.exe package now.

Windows Media Player 9 Series for Windows 2000 and Windows Server 2003

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsMedia9-KB884267-x86-ENU.exe package now.

Windows Media Player 10

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsMedia10-KB884267-x86-ENU.exe package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Media Player 9 Series

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Aug-2004  19:13  9.0.0.3251      1,025,024  Wmnetmgr.dll     

Windows Media Player 10

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Nov-2004  01:35  10.0.0.3652     1,026,048  Wmnetmgr.dll     

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbQFE kbHotfixServer KB884267 kbAudDeveloper kbAudEndUser