Not all Halo servers are listed in Halo: Combat Evolved (884129)



The information in this article applies to:

  • Microsoft Halo: Combat Evolved

SYMPTOMS

When you try to list the available Microsoft Halo: Combat Evolved multiplayer servers, not all the servers are listed. Additionally, you may receive an error message that states that your Microsoft Halo client is an earlier version than the version of the Halo server that you are trying to connect to.

CAUSE

This problem may occur in one of the following scenarios:
  • The locked status, the dedicated server status, or the classic Halo content status filters have been enabled.
  • The Halo.exe file is damaged or has been incorrectly updated, or the Halo.exe file has been replaced with a third-party version.

RESOLUTION

To resolve this problem, use one of the following methods, depending on your scenario.

Method 1

Disable all Halo server filters. To do this, follow these steps:
  1. Start Halo.
  2. On the Halo main screen, click Multiplayer.
  3. Under Join Game, click Internet.
  4. In Internet Lobby, click Get List to obtain a list of the games that are available.
  5. Click the locked status icon at the top of the first column of the list to disable the filter.

    Note A blue locked status icon shows locked and unlocked games and a green icon shows only unlocked games.
  6. Click the dedicated server status icon at the top of the second column of the list to disable the filter.

    Note A blue dedicated server status icon shows all the server types and a green icon shows only dedicated servers.
  7. Click the classic Halo content status icon at the top of the fifth column of the list to disable.

    Note A blue classic Halo content status icon shows all game types and a green icon shows only classic Halo content games.
  8. Clear any additional filters. To do this, follow these steps:
    1. In Internet Lobby, click Filters.
    2. Change the filter settings to the following:
      Show Empty ServersYes
      Show Full ServersYes
      PingAny
      Game TypeAny
      Teamplay OptionsAny
    3. Click OK.
  9. To obtain a list of available games, click Get List.
Note After you click Get List, a full list of servers will appear.

Method 2

Remove and then replace the Halo.exe file. To do this, follow these steps:
  1. Locate the Halo.exe file in the following folder on your hard disk:

    C:\Program Files\Microsoft Games\Halo

  2. Right-click the Halo.exe file, and then click Delete. If you are prompted to approve the deletion, click OK.
  3. Insert the Halo: Combat Evolved CD into your CD drive or your DVD drive.
  4. Locate the Halo.exe file in the following folder on the CD:

    drive:\Files

    In this example, drive is the drive letter for your CD drive or your DVD drive.
  5. Right-click the Halo.exe file, and then click Copy.
  6. Open the C:\Program Files\Microsoft Games\Halo folder.
  7. Right-click in the C:\Program Files\Microsoft Games\Halo folder, and then click Paste.
The Halo.exe file is copied into the C:\Program Files\Microsoft Games\Halo folder.

Method 3

If manually replacing the Halo.exe file does not resolve the problem, remove and then reinstall Halo: Combat Evolved. To do this, follow these steps:
  1. Click Start, Click Run, type appwiz.cpl, and then click OK.
  2. In the list of installed programs, locate Microsoft Halo: Combat Evolved, and then click Remove.
  3. Follow the instructions that appear on the screen to complete the removal process.
  4. Insert the game CD disc into the CD drive or the DVD drive.
  5. Follow the instructions that appear on the screen to complete the installation process.
If the Setup program does not start automatically, follow these steps:
  1. Click Start, click Run, and then type drive:\setup.exe. In this example, drive is the drive letter of the CD drive or the DVD drive.
  2. Click OK.
  3. Follow the instructions that appear on the screen to complete the installation process.

Modification Type:MinorLast Reviewed:1/19/2006
Keywords:kbConfig kbsetup kbtshoot kbprb KB884129 kbAudEndUser