Storage medium errors cause an unexpected program crash in Windows Server 2003 and in Windows XP (884070)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition

SYMPTOMS

When you start or run a program in Microsoft Windows XP, the program may crash when it tries to read valid data from or write valid data to a storage medium. For example, the program may crash when it tries to read valid data from a hard disk. You may receive the following error message:
Program_name has caused an error and must be closed.
We apologize for the inconvenience. If you were in the middle of something, the information you were working on might be lost.
Please tell Microsoft about this problem. We have created an error report that you can send to help us improve Program_name. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.

CAUSE

This problem occurs when Windows XP cannot access a file because of a problem with the hard disk that the file is stored on or with the drivers for a storage medium. When this problem occurs, Windows XP closes the program.

WORKAROUND

To work around this problem, follow these steps:
  1. Identify the file that cannot be opened. To identify the file, follow these steps:
    1. Click Start, click Run, type EVENTVWR, and then click OK.
    2. In Event Viewer, click Application log.
    3. Click the Source column heading to sort the list by source and to list all the Application Error sources at the top of the list.
    4. Search for an event with a source of Application Error and an event ID of 1005.
    5. Double-click this event.
    6. The file that cannot be opened will be listed in the Description box. Note the file name, and then close Event Properties.
  2. Try to open the file again. The problem may have been temporary and may not occur when the program runs again.
  3. If you cannot open the file, verify and repair the hard disk file system with the Chkdsk.exe program. Follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type chkdsk /f, and then press ENTER.

      You are prompted to schedule Chkdsk to run when the computer restarts.
    3. Press Y.
    4. Restart the computer.
  4. Determine whether other files on the same hard disk can be opened. If not, the hard disk may be damaged. If the hard disk is the problem, contact your administrator or computer hardware vendor for more help.
Note You may have to restore the file in question from a backup copy. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

309340 How to use Backup to restore files and folders on your computer in Windows XP

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The Error Reporting dialog box appears when an error occurs that causes a fatal event in the program. Error Reporting includes an option to send the information about the fatal event to Microsoft. Microsoft gathers information about these types of events in a database to try to identify the cause. For more information about the Microsoft Data Collection Policy, visit the following Microsoft Web site: The following error signature applies to the error message that is mentioned in the "Symptoms" section.
EventTypeNameNTStatusCode
InPageError c000009c or C0000185 or C0000102 or C000003F or 00000002 or 00000003

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbDRWatson kberrmsg kbtshoot kbprb KB884070 kbAudEndUser kbAudITPRO