Your system stops responding when you continuously create and then delete Volume Shadow Copy Service snapshots in Windows Server 2003 (884055)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

Assume the following scenario:
  1. You create a Volume Shadow Copy Service snapshot.
  2. You copy the snapshot to a storage device.
  3. You delete the original snapshot.
  4. You immediately repeat this process with a new snapshot in a lengthy series of snapshots.
After approximately 30 minutes of repeating this process, your Microsoft Windows Server 2003-based computer stops responding (hangs).

CAUSE

This issue occurs because of a problem in the Volsnap.sys driver file that implements the process for creating and for deleting snapshots in the Volume Shadow Copy Service. In this scenario, the shadow copy storage area grows every time that you create and then delete a Volume Shadow Copy Service snapshot.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 64-bit version
Date         Time   Version            Size    File name     Platform  
----------------------------------------------------------------------
21-Sep-2004  12:24  5.2.3790.212      706,048  Swprv.dll        IA-64
21-Sep-2004  11:51  5.2.3790.215      348,672  Volsnap.sys
21-Sep-2004  12:24  5.2.3790.212    1,351,168  Vssapi.dll       IA-64
18-Sep-2004  22:45  5.2.3790.212    1,793,536  Vssvc.exe        IA-64
21-Sep-2004  12:24  5.2.3790.212       28,160  Vss_ps.dll       IA-64
18-Sep-2004  21:13  5.2.3790.212       58,880  Ws03res.dll      IA-64
21-Sep-2004  12:22  5.2.3790.212      544,768  Wvssapi.dll      x86
21-Sep-2004  12:22  5.2.3790.212       18,432  Wvss_ps.dll      x86
18-Sep-2004  23:11  5.2.3790.212       59,392  Wws03res.dll     x86   
Windows Server 2003 32-bit version
Date         Time   Version            Size    File name
----------------------------------------------------------
22-Sep-2004  00:52  5.2.3790.212      273,920  Swprv.dll        
22-Sep-2004  00:25  5.2.3790.215      116,736  Volsnap.sys
22-Sep-2004  00:52  5.2.3790.212      544,768  Vssapi.dll       
19-Sep-2004  10:52  5.2.3790.212      663,552  Vssvc.exe        
22-Sep-2004  00:52  5.2.3790.212       18,432  Vss_ps.dll       
19-Sep-2004  11:41  5.2.3790.212       59,392  Ws03res.dll         

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB884055 kbAudITPRO