You cannot add a Windows component in Windows XP (884018)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you try to add a Windows component after you first install Microsoft Windows XP, you cannot add the component, and you may receive a message that is similar to the following:
Files Needed
The file 'file_name' on Windows XP Professional CD-ROM is needed.
Type the path where the file is located, and then click OK.
This problem occurs even though the file already exists in the C:\Windows\I386 folder. When you provide the path of the file, the error message reappears.

When this error occurs, an entry that is similar to the following appears in the C:\Windows\Security\logs\scecomp.log file:
Date_Time Error=1208 Update File
C:\WINDOWS\system32\file_name
Security=D:P(A;;GRGX;;;BU)(A;;GRGX;;;PU)(A;;GA;;;BA)(A;;GA;;;SY)(A;;GRGX;;;WD)
This issue has also been found to prevent third-party hardware and software from installing. Specifically, you may experience this symptom after you install Windows XP Service Pack 2 (SP2) on a computer that has a built-in Atheros wireless network device and when you then try to install a Bluetooth device.

This problem occurs when you try to install one or more of the following Windows components:
  • Accessories and Utilities
  • Fax services
  • Indexing Service
  • Internet Explorer
  • Internet Information Services (IIS)
  • Management and Monitoring Tools
  • Message Queuing
  • MSN Explorer
  • Networking Services
  • Other Network File and Print Services
  • Outlook Express
  • Update Root Certificates
  • Windows Media Player
  • Windows Messenger

CAUSE

This problem occurs because the security database is corrupted.

RESOLUTION

Note We do not recommend that you use the Esentutl.exe utility to recover from security database corruption. The Esentutl.exe utility fixes corruption by deleting data from the database and could possibly permanently mark Group Policy settings in the registry. Only use this kind of repair as a last resort.

To resolve this problem, rebuild the corrupted security database. For additional information about how to rebuild a corrupted security database, click the following article number to view the article in the Microsoft Knowledge Base:

278316 ESENT Event IDs 1000, 1202, 412, and 454 are logged repeatedly in the application event log



To prevent this problem from occurring when Windows XP is installed, contact Microsoft Product Support Services to obtain the following hotfix package. To use the updated fix that is contained in this hotfix, create a Windows XP distribution file share, and then replace the existing driver with the updated driver that is contained in this hotfix. This will prevent the problem that is described in the Symptoms section from occuring when Windows XP is installed. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

828930 How to integrate software updates into your Windows installation source files

You must follow the instructions in Knowledge Base article 828930 to slipstream the hotfix to your distribution file share.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name  SP level
   ---------------------------------------------------------------
   12-Aug-2004  20:44  5.1.2600.1582  302,592  Scesrv.dll   SP1QFE 
   12-Aug-2004  20:26  5.1.2600.2505  313,856  Scesrv.dll   SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kberrmsg kbfix kbbug kbQFE kbHotfixServer KB884018 kbAudEndUser kbAudOEM